dev-php/pecl-mcrypt: bump to 1.0.2
authorTomas Mozes <hydrapolic@gmail.com>
Thu, 17 Jan 2019 09:23:12 +0000 (10:23 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 19 Jan 2019 03:21:46 +0000 (04:21 +0100)
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10854
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/pecl-mcrypt/Manifest
dev-php/pecl-mcrypt/pecl-mcrypt-1.0.2.ebuild [new file with mode: 0644]

index acfd97228a2e50c41bf6b0296b42ae35bd20a889..d57637f516749a91c59523e2a5a7f55c1a3943cb 100644 (file)
@@ -1 +1,2 @@
 DIST mcrypt-1.0.1.tgz 33782 BLAKE2B db5f89fdbc64c81bd50c92301155527f40b28cd274312565c79327133baa20e14c488f8ad1f87e6ddfd3ced9706ca30f10dc69a08279c82c9ec83fb5f713e826 SHA512 1677202715499a41ac6999089257a059106e58cbac06ca8a7dd2e9edd28be5a4118234dd7468110e9e3d7f9de5d099367848fe84bcd06716ea56645c9015c578
+DIST mcrypt-1.0.2.tgz 33698 BLAKE2B b79985455986ca28e7cb55d3f6f62f87e1112f57c4e26761a08a2d9ce7c702cf325fccb50f703cfe5c570c7e3abc473030742f098b10e709145f7ac9676f834a SHA512 bf3796b60f1d8d34185c3ad0d813653fe64ccfc883106ba544b01a8caa7bf9729978f44e0d481d28af9f8827803dcc5cd8bfc83e50dc950d26f851fabc868b18
diff --git a/dev-php/pecl-mcrypt/pecl-mcrypt-1.0.2.ebuild b/dev-php/pecl-mcrypt/pecl-mcrypt-1.0.2.ebuild
new file mode 100644 (file)
index 0000000..078d2ac
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="mcrypt"
+USE_PHP="php7-2 php7-3"
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_ECONF_ARGS=()
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="Bindings for the libmcrypt library"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/libmcrypt"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       # PHP Warning: Use of undefined constant MCRYPT_CBC - assumed 'MCRYPT_CBC'
+       sed -i '/MODE3/s/MCRYPT_CBC/"MCRYPT_CBC"/g' tests/bug8040.phpt || die
+
+       php-ext-source-r3_src_prepare
+}