net-analyzer/nagios-check_dnssec: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 18 Jan 2020 17:35:37 +0000 (18:35 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 18 Jan 2020 17:35:37 +0000 (18:35 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
net-analyzer/nagios-check_dnssec/nagios-check_dnssec-0.1_p28.ebuild

index e83bff31808caa31bea7b3139b5650ac2f4bfab4..ed5fc8bb0488a2038f31a6b0fd2c73653cc42c38 100644 (file)
@@ -1,30 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit eutils autotools
-DESCRIPTION="check_dnssec is a set of Nagios plugins to monitor DNSSEC services"
-HOMEPAGE="https://svn.durchmesser.ch/trac/check_dnssec"
+inherit autotools
 
 MY_P=${P/nagios-/}
 
+DESCRIPTION="check_dnssec is a set of Nagios plugins to monitor DNSSEC services"
+HOMEPAGE="https://svn.durchmesser.ch/trac/check_dnssec"
 # No upstream tarballs, tagged releaess in SVN only.
 SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
 LICENSE="GPL-3"
 SLOT="0"
-
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 
-DEPEND="|| ( net-analyzer/nagios-plugins net-analyzer/monitoring-plugins )
-               net-libs/ldns"
+DEPEND="
+       || (
+               net-analyzer/nagios-plugins
+               net-analyzer/monitoring-plugins
+       )
+       net-libs/ldns"
 RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${MY_P}"
 
 src_prepare() {
+       default
        eautoreconf
 }
-
-DOCS=( ChangeLog README AUTHORS )