sys-devel/patch: Rev bump to fix test suite
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 12 Feb 2018 15:14:13 +0000 (16:14 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 12 Feb 2018 15:14:13 +0000 (16:14 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

sys-devel/patch/files/patch-2.7.6-fix-test-suite.patch [new file with mode: 0644]
sys-devel/patch/patch-2.7.6-r1.ebuild [moved from sys-devel/patch/patch-2.7.6.ebuild with 94% similarity]

diff --git a/sys-devel/patch/files/patch-2.7.6-fix-test-suite.patch b/sys-devel/patch/files/patch-2.7.6-fix-test-suite.patch
new file mode 100644 (file)
index 0000000..3aff5c0
--- /dev/null
@@ -0,0 +1,120 @@
+http://git.savannah.gnu.org/cgit/patch.git/commit/?id=f6bc5b14bd193859851d15a049bafb1007acd288
+http://git.savannah.gnu.org/cgit/patch.git/commit/?id=074e2395f81d0ecaa66b71a6c228c70b49db72e5
+
+--- a/tests/crlf-handling
++++ b/tests/crlf-handling
+@@ -14,7 +14,7 @@ use_local_patch
+ use_tmpdir
+ lf2crlf() {
+-    while read l; do echo -e "$l\r"; done
++    while read l; do printf "%s\r\n" "$l"; done
+ }
+ echo 1 > a
+--- a/tests/git-cleanup
++++ b/tests/git-cleanup
+@@ -36,8 +36,8 @@ BAD PATCH
+ EOF
+ echo 1 > f
+-echo -n '' > g
+-echo -n '' > h
++printf '' > g
++printf '' > h
+ check 'patch -f -i 1.diff || echo status: $?' <<EOF
+ patching file f
+--- a/tests/merge
++++ b/tests/merge
+@@ -30,30 +30,28 @@ x2() {
+     while test $# -gt 0 && test "$1" != -- ; do
+       echo "$1"
+       shift
+-    done > a.sed
+-    echo "$body" | sed -f a.sed > b
++    done > b.sed
++    echo "$body" | sed -f b.sed > b
+     shift
+     while test $# -gt 0 ; do
+       echo "$1"
+       shift
+-    done > b.sed
+-    echo "$body" | sed -f b.sed > c
+-    rm -f a.sed b.sed
++    done > c.sed
++    echo "$body" | sed -f c.sed > c
++    rm -f b.sed c.sed
+     output=`diff -u a b | patch $ARGS -f c`
+     status=$?
+     echo "$output" | sed -e '/^$/d' -e '/^patching file c$/d'
+     cat c
+-    test $status == 0 || echo "Status: $status"
++    test $status = 0 || echo "Status: $status"
+ }
+ x() {
+-    ARGS="$ARGS --merge" x2 "$@"
++    ARGS="--merge" x2 "$@"
+     echo
+-    ARGS="$ARGS --merge=diff3" x2 "$@"
++    ARGS="--merge=diff3" x2 "$@"
+ }
+-unset ARGS
+-
+ # ==============================================================
+ check 'x 3' <<EOF
+--- a/tests/test-lib.sh
++++ b/tests/test-lib.sh
+@@ -41,7 +41,7 @@ use_local_patch() {
+     eval 'patch() {
+       if test -n "$GDB" ; then
+-        echo -e "\n" >&3
++        printf "\n\n" >&3
+         gdbserver localhost:53153 $PATCH "$@" 2>&3
+       else
+           $PATCH "$@"
+@@ -113,22 +113,15 @@ cleanup() {
+     exit $status
+ }
+-if test -z "`echo -n`"; then
+-    if eval 'test -n "${BASH_LINENO[0]}" 2>/dev/null'; then
+-      eval '
+-          _start_test() {
+-              echo -n "[${BASH_LINENO[2]}] $* -- "
+-          }'
+-    else
+-      eval '
+-          _start_test() {
+-              echo -n "* $* -- "
+-          }'
+-    fi
++if eval 'test -n "${BASH_LINENO[0]}" 2>/dev/null'; then
++    eval '
++      _start_test() {
++          printf "[${BASH_LINENO[2]}] %s -- " "$*"
++      }'
+ else
+     eval '
+       _start_test() {
+-          echo "* $*"
++          printf "* %s -- " "$*"
+       }'
+ fi
+--- a/tests/merge
++++ b/tests/merge
+@@ -32,7 +32,7 @@ x2() {
+       shift
+     done > b.sed
+     echo "$body" | sed -f b.sed > b
+-    shift
++    test $# -eq 0 || shift
+     while test $# -gt 0 ; do
+       echo "$1"
+       shift
+-- 
similarity index 94%
rename from sys-devel/patch/patch-2.7.6.ebuild
rename to sys-devel/patch/patch-2.7.6-r1.ebuild
index b16c1511b8888691d2335c98a76b0f610dc42a41..388826a546a1183adde92ceaa9de07a1390ca409 100644 (file)
@@ -18,6 +18,8 @@ RDEPEND="xattr? ( sys-apps/attr )"
 DEPEND="${RDEPEND}
        test? ( sys-apps/ed )"
 
+PATCHES=( "${FILESDIR}"/${P}-fix-test-suite.patch )
+
 src_configure() {
        use static && append-ldflags -static