Fix Python dependencies in ebuildtester
authorViktar Patotski (aka xp-vit) <xp.vit.blr@gmail.com>
Thu, 26 Mar 2020 13:58:31 +0000 (14:58 +0100)
committerNicolas Bock <nicolasbock@gentoo.org>
Fri, 27 Mar 2020 12:13:25 +0000 (06:13 -0600)
Closes: https://bugs.gentoo.org/686850
Closes: https://bugs.gentoo.org/685274
Signed-off-by: Viktar Patotski <xp.vit.blr@gmail.com>
Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
dev-python/ebuildtester/ebuildtester-0.1.16.ebuild

index db6d15de38e103e499df9d1cb4101e763ab35744..4c8e03cd5df0548d57e6788a215690246753f7cf 100644 (file)
@@ -3,12 +3,12 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit bash-completion-r1 distutils-r1
 
 DESCRIPTION="A dockerized approach to test a Gentoo package within a clean stage3 container"
-HOMEPAGE="http://ebuildtester.readthedocs.io/"
+HOMEPAGE="https://ebuildtester.readthedocs.io/"
 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="BSD"
@@ -23,6 +23,7 @@ RDEPEND="
 
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
        dev-python/sphinx[${PYTHON_USEDEP}]
 "