media-sound/spotify: minor cleanups to old ebuilds
authorNikos Chantziaras <realnc@gmail.com>
Sat, 18 Aug 2018 15:01:54 +0000 (18:01 +0300)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 18 Aug 2018 20:22:27 +0000 (15:22 -0500)
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
media-sound/spotify/spotify-1.0.72.ebuild
media-sound/spotify/spotify-1.0.80.ebuild

index 3b8d57bd25aac8f847f4c0389fbbd52206ae8a2b..b4ac3c597ade455fbc5cc5ee1e3b8cc57d2a87d9 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit eutils xdg-utils gnome2-utils pax-utils unpacker
+inherit gnome2-utils pax-utils unpacker xdg-utils
 
 DESCRIPTION="Spotify is a social music platform"
 HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
@@ -19,7 +19,7 @@ IUSE="libnotify systray pax_kernel pulseaudio"
 RESTRICT="mirror strip"
 
 DEPEND=""
-# zenety needed for filepicker
+# zenity needed for filepicker
 RDEPEND="
        ${DEPEND}
        dev-libs/nss
@@ -94,10 +94,6 @@ src_install() {
        fi
 }
 
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
 pkg_postinst() {
        gnome2_icon_cache_update
        xdg_mimeinfo_database_update
@@ -106,11 +102,6 @@ pkg_postinst() {
        ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
        ewarn "To remove the cache:"
        ewarn "rm -rf ~/.cache/spotify"
-       ewarn
-       ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
-       ewarn "Run"
-       ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
-       ewarn "Then log out and log in back to KDE."
 }
 
 pkg_postrm() {
index da910ba96d62d687e7685e23004962fbe0e46fa9..ae609de2a96ef3375593bab0b9c8a82d44f900f9 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit eutils xdg-utils gnome2-utils pax-utils unpacker
+inherit gnome2-utils pax-utils unpacker xdg-utils
 
 DESCRIPTION="Spotify is a social music platform"
 HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
@@ -19,7 +19,7 @@ IUSE="libnotify systray pax_kernel pulseaudio"
 RESTRICT="mirror strip"
 
 DEPEND=">=dev-util/patchelf-0.9_p20180129"
-# zenety needed for filepicker
+# zenity needed for filepicker
 RDEPEND="
        dev-libs/openssl:0
        dev-libs/nss
@@ -98,10 +98,6 @@ src_install() {
        fi
 }
 
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
 pkg_postinst() {
        gnome2_icon_cache_update
        xdg_mimeinfo_database_update
@@ -110,11 +106,6 @@ pkg_postinst() {
        ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
        ewarn "To remove the cache:"
        ewarn "rm -rf ~/.cache/spotify"
-       ewarn
-       ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
-       ewarn "Run"
-       ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
-       ewarn "Then log out and log in back to KDE."
 }
 
 pkg_postrm() {