app-office/gnucash: Fix check_symbol_exists error
authorPeter Levine <plevine457@gmail.com>
Sun, 15 Sep 2019 19:58:05 +0000 (15:58 -0400)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 13 Oct 2019 11:40:24 +0000 (13:40 +0200)
Adds "include(CheckSymbolExists)" to avoid the error
"Unknown CMake command check_symbol_exists"

Closes: https://bugs.gentoo.org/690270
Package-Manager: Portage-2.3.75, Repoman-2.3.17
Signed-off-by: Peter Levine <plevine457@gmail.com>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch [new file with mode: 0644]
app-office/gnucash/gnucash-3.7.ebuild

diff --git a/app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch b/app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch
new file mode 100644 (file)
index 0000000..c0e1778
--- /dev/null
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/690270
+
+--- a/gnucash/register/register-gnome/CMakeLists.txt
++++ b/gnucash/register/register-gnome/CMakeLists.txt
+@@ -1,5 +1,7 @@
+ add_subdirectory(test)
++include(CheckSymbolExists)
++
+ #GTK before 3.14 didn't have GDK_MODIFIER_INTENT_DEFAULT_MOD_MASK
+ check_symbol_exists(GDK_MODIFIER_INTENT_DEFAULT_MOD_MASK gdk/gdktypes.h have_mod_mask)
+ if (NOT have_mod_mask)
index ec42d91eaae7b7c22298b4d731ac03e63fe86ed3..4b8e26a831cd159430079f58fa498c0fb2e1b5d6 100644 (file)
@@ -80,7 +80,10 @@ PDEPEND="doc? (
        gnome-extra/yelp
 )"
 
-PATCHES=( "${FILESDIR}"/${PN}-3.2-no-gui.patch )
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.2-no-gui.patch
+       "${FILESDIR}"/${PN}-3.7-include-checksymbolexists.patch
+)
 
 pkg_setup() {
        use python && python-single-r1_pkg_setup