games-util/pyfa: update live ebuild
authorAndreas Zuber <a.zuber@gmx.ch>
Tue, 28 Apr 2020 08:01:55 +0000 (10:01 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 29 Apr 2020 10:15:43 +0000 (13:15 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Zuber <a.zuber@gmx.ch>
Closes: https://github.com/gentoo/gentoo/pull/15552
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
games-util/pyfa/pyfa-9999.ebuild

index 145ca005c0d10b5febc7ff60e9770dd0b38e8ddc..254447e150c898780fe18949ac384aa301294623 100644 (file)
@@ -2,8 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="7"
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,threads"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
 
 inherit desktop eutils python-single-r1 xdg-utils
 
@@ -18,9 +19,9 @@ if [[ ${PV} = 9999 ]]; then
 else
        SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~x86"
-       S=${WORKDIR}/Pyfa-${PV}
+       S="${WORKDIR}/Pyfa-${PV}"
 fi
-IUSE=""
+
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 RESTRICT="mirror bindist"
 
@@ -49,7 +50,7 @@ BDEPEND="app-arch/zip"
 PATCHES=(
        # fix import path in the main script for systemwide installation
        "${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
-       )
+)
 
 src_prepare() {
        # get rid of CRLF line endings introduced in 1.1.10 so patches work