dev-python/diff-match-patch: 20181111
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Mon, 16 Dec 2019 08:28:58 +0000 (09:28 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sat, 21 Dec 2019 15:30:51 +0000 (16:30 +0100)
Bug: https://bugs.gentoo.org/702458
Closes: https://github.com/gentoo/gentoo/pull/13998
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.81, Repoman-2.3.20

dev-python/diff-match-patch/Manifest
dev-python/diff-match-patch/diff-match-patch-20181111.ebuild [new file with mode: 0644]

index 4ebad66ede4087ff101eca2c6fad50eab9abdfe3..06b4f7187b9967a7bcf6772e90f5a26979abc47d 100644 (file)
@@ -1 +1,2 @@
 DIST diff-match-patch-20121119.tar.gz 54113 BLAKE2B 0fcfa46f02f92af0e31ded7c51c651574104fb4d7d70082873981138579b12231dea0eee417614981a96f7ceaa50b288fefdbc21dca687451095dcdc34fe32f8 SHA512 3daff80a6043a0413c515125a21839d9fa1d71f7e2441f4870ebefed35f1accea711814ad231c65de0e3468bbd01402c977fc063ab120b7d9f0e04ef555a8207
+DIST diff-match-patch-20181111.tar.gz 58554 BLAKE2B 2a74294bb9ac88447cdea794a9c3b44d705d93f7e0777d5e5ece4a306f43df47458a4ba0ec8b16624862a6e4540a605695c3a83ee7dad7749b22210ebe65705a SHA512 9b21726b9c0e350553533c14dd86cca823c6f98ab642e7166cf9348952a57b62bcb0576e3d6a3b76655ea1bcc8cef3fe7f33ffb068b5a4bfb4b4b521042484e6
diff --git a/dev-python/diff-match-patch/diff-match-patch-20181111.ebuild b/dev-python/diff-match-patch/diff-match-patch-20181111.ebuild
new file mode 100644 (file)
index 0000000..bde087e
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="https://pypi.org/project/diff-match-patch/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest