net-analyzer/wireshark: Add some test requirements
authorJeroen Roovers <jer@gentoo.org>
Sun, 26 Apr 2020 10:36:27 +0000 (12:36 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 26 Apr 2020 10:39:18 +0000 (12:39 +0200)
According to test/README.test:
- pytest{,-xdist} are needed
- the test-programs target needs to be built (manually)

This should allow the suite_unittests target to pass.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/wireshark/wireshark-3.2.3.ebuild
net-analyzer/wireshark/wireshark-99999999.ebuild

index a09e19cba2a7e5412573b7ed2cd0a4fe3ee11e14..032bafbb15ba23ad86c07135011651b87488901d 100644 (file)
@@ -17,7 +17,7 @@ IUSE="
        +dumpcap +editcap http2 kerberos libxml2 lua lz4 maxminddb +mergecap
        +minizip +netlink +plugins plugin-ifdemo +pcap +qt5 +randpkt +randpktdump
        +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
-       +text2pcap tfshark +tshark +udpdump zlib +zstd
+       test +text2pcap tfshark +tshark +udpdump zlib +zstd
 "
 S=${WORKDIR}/${P/_/}
 
@@ -74,6 +74,10 @@ BDEPEND="
        qt5? (
                dev-qt/linguist-tools:5
        )
+       test? (
+               dev-python/pytest
+               dev-python/pytest-xdist
+       )
 "
 RDEPEND="
        ${CDEPEND}
@@ -174,6 +178,7 @@ src_configure() {
 }
 
 src_test() {
+       cmake_build test-programs
        cmake_src_test
 }
 
index 6f9470ca6ee5d086208bbaf44a3042ab584358eb..86206f1ead23a692afba9642091ecc19c908a00b 100644 (file)
@@ -17,7 +17,7 @@ IUSE="
        +dumpcap +editcap http2 kerberos libxml2 lua lz4 maxminddb +mergecap
        +minizip +netlink +plugins plugin-ifdemo +pcap +qt5 +randpkt +randpktdump
        +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
-       +text2pcap tfshark +tshark +udpdump zlib
+       test +text2pcap tfshark +tshark +udpdump zlib
 "
 S=${WORKDIR}/${P/_/}
 
@@ -73,6 +73,10 @@ BDEPEND="
        qt5? (
                dev-qt/linguist-tools:5
        )
+       test? (
+               dev-python/pytest
+               dev-python/pytest-xdist
+       )
 "
 RDEPEND="
        ${CDEPEND}
@@ -168,6 +172,7 @@ src_configure() {
 }
 
 src_test() {
+       cmake_build test-programs
        cmake_src_test
 }