app-vim/splice: add python3.6 support.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 13 Dec 2019 08:31:04 +0000 (09:31 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 13 Dec 2019 08:31:04 +0000 (09:31 +0100)
Closes: https://bugs.gentoo.org/658840
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-vim/splice/splice-1.1.0-r1.ebuild [new file with mode: 0644]

diff --git a/app-vim/splice/splice-1.1.0-r1.ebuild b/app-vim/splice/splice-1.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..3753a52
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_6 )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: resolve conflicts during three-way merges"
+HOMEPAGE="https://bitbucket.org/sjl/splice.vim/ https://www.vim.org/scripts/script.php?script_id=4026"
+SRC_URI="https://bitbucket.org/sjl/${PN}.vim/get/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+       ${PYTHON_DEPS}
+       || (
+               app-editors/vim[python,${PYTHON_USEDEP}]
+               app-editors/gvim[python,${PYTHON_USEDEP}]
+       )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+       default
+       rm .[a-z]* Makefile LICENSE.markdown package.sh || die
+       rm -r site || die
+}
+
+src_install() {
+       vim-plugin_src_install
+       python_optimize "${ED}"/usr/share/vim/vimfiles/autoload/splicelib
+}