x11-misc/colord: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 17:29:26 +0000 (19:29 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 17:31:28 +0000 (19:31 +0200)
Package-Manager: portage-2.2.20.1

x11-misc/colord/Manifest
x11-misc/colord/colord-1.2.12.ebuild [new file with mode: 0644]

index 029df26c031f396fef133f4322f7485114620f12..55fb4ba0e14bb68c1b7aee0897d08f8278ee32a0 100644 (file)
@@ -1,3 +1,4 @@
 DIST colord-1.2.10.tar.xz 1203248 SHA256 1dea0453cc778326e700f6cb0a206836a57dedfb0fbdc3acaf2be02ea77a963a SHA512 fdf6f41e84fb37905e3c2e37a7d095d5271759f17e292cf5cf23f846ea6805949185c1a0548c4c4e24e2a385e655cd30609423921b0389076f5373ca1b8578e7 WHIRLPOOL d70fd0d3fde030f6c592f49ae146ccbb38c00ad0c28e2253ea8e2e00436c19fc4cf53aead6360e04eb7509a8d94bd07ffab6dde5592fd050dd37de3355b76f87
 DIST colord-1.2.11.tar.xz 1205468 SHA256 dac29c83659703a8548db561bc670832f26b30f7a88ed90a6530eb052a10df8f SHA512 fec46d295b1b4caba7c0a666eccbf3ce325fab4bd56e6a841cfdd9b7a381384dff3c71a744dda0e88ed2e99519c278c1ee495e6b8870c74cb4939dbc08d4bb96 WHIRLPOOL 7372d1a52c897e133fa75c8e06c47b3f7035cb01a3ec858f74ddc741613b11554a2d6dac6c886347f4e82baa16091cc41232a5deb3db4ae5a4930be0d1de6f41
+DIST colord-1.2.12.tar.xz 245293 SHA256 2c88a8e7ac184a5efc68a8019fd544eb020390ca03dbe38e09b19302a2dfd938 SHA512 51b542a4dbbdff067b6aaa0b730c4d7725a3b42af578c98a17bed9baaf89bbcb287d816fa0096893c40a04b871949886240f94c663e45cbe6380c00fc2f80a47 WHIRLPOOL 8dac67867e18fadc9d19d92d735bd6c1bfbeeee9a8943f0106e6df2b5eaa75ff559ec34d38279a1caf51792c3eb021f403fc49928193b419bceeaf42525fb095
 DIST colord-1.2.9.tar.xz 1200936 SHA256 48ce0db4f327c94c2bec11fed98a9a73f580d34c6edcd636d90831fe3bea5ae4 SHA512 d25497fa6460e5ffd7ce872bf16b60916e879cdd3aaec4c81dd4ab8446949767f3d3d49a3e654813445b049a9653334ba22d8e9a91cf6699c6063c01be382a75 WHIRLPOOL ca8edc19b162e4e97c263c1bc64d2a655d5adafeb2cb64c8bdbd7eb4e20052ce76f8ad332168088a97e654d20f0c5215d62829fed7471ac69faed3a79fc9f283
diff --git a/x11-misc/colord/colord-1.2.12.ebuild b/x11-misc/colord/colord-1.2.12.ebuild
new file mode 100644 (file)
index 0000000..8e4bdf7
--- /dev/null
@@ -0,0 +1,171 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools bash-completion-r1 check-reqs eutils gnome2 user systemd udev vala multilib-minimal
+
+DESCRIPTION="System service to accurately color manage input and output devices"
+HOMEPAGE="http://www.freedesktop.org/software/colord/"
+SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/2" # subslot = libcolord soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+# We prefer policykit enabled by default, bug #448058
+IUSE="argyllcms examples extra-print-profiles +gusb +introspection +policykit scanner systemd +udev vala"
+REQUIRED_USE="
+       gusb? ( udev )
+       scanner? ( udev )
+       vala? ( introspection )
+"
+
+COMMON_DEPEND="
+       dev-db/sqlite:3=
+       >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+       >=media-libs/lcms-2.6:2=[${MULTILIB_USEDEP}]
+       argyllcms? ( media-gfx/argyllcms )
+       gusb? ( >=dev-libs/libgusb-0.2.2[introspection?,${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+       policykit? ( >=sys-auth/polkit-0.103 )
+       scanner? (
+               media-gfx/sane-backends
+               sys-apps/dbus )
+       systemd? ( >=sys-apps/systemd-44:0= )
+       udev? (
+               virtual/udev
+               virtual/libgudev:=
+               virtual/libudev:=[${MULTILIB_USEDEP}]
+       )
+"
+RDEPEND="${COMMON_DEPEND}
+       !media-gfx/shared-color-profiles
+       !<=media-gfx/colorhug-client-0.1.13
+"
+DEPEND="${COMMON_DEPEND}
+       dev-libs/libxslt
+       >=dev-util/gtk-doc-am-1.9
+       >=dev-util/intltool-0.35
+       >=sys-devel/gettext-0.17
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+       extra-print-profiles? ( media-gfx/argyllcms )
+       vala? ( $(vala_depend) )
+"
+
+# FIXME: needs pre-installed dbus service files
+RESTRICT="test"
+
+# According to upstream comment in colord.spec.in, building the extra print
+# profiles requires >=4G of memory
+CHECKREQS_MEMORY="4G"
+
+pkg_pretend() {
+       use extra-print-profiles && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+       use extra-print-profiles && check-reqs_pkg_setup
+       enewgroup colord
+       enewuser colord -1 -1 /var/lib/colord colord
+}
+
+src_prepare() {
+       # Adapt to Gentoo paths
+       sed -i -e 's/spotread/argyll-spotread/' \
+               src/sensors/cd-sensor-argyll.c \
+               configure.ac || die
+
+       eautoreconf
+       use vala && vala_src_prepare
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       # Reverse tools require gusb
+       # bash-completion test does not work on gentoo
+       local myconf=(
+               --disable-bash-completion
+               --disable-examples
+               --disable-static
+               --enable-libcolordcompat
+               --with-daemon-user=colord
+               --localstatedir="${EPREFIX}"/var
+               $(multilib_native_use_enable argyllcms argyllcms-sensor)
+               $(multilib_native_use_enable extra-print-profiles print-profiles)
+               $(multilib_native_usex extra-print-profiles COLPROF="$(type -P argyll-colprof)" "")
+               $(use_enable gusb)
+               $(multilib_native_use_enable gusb reverse)
+               $(multilib_native_use_enable introspection)
+               $(multilib_native_use_enable policykit polkit)
+               $(multilib_native_use_enable scanner sane)
+               $(multilib_native_use_enable systemd systemd-login)
+               $(use_enable udev)
+               --with-udevrulesdir="$(get_udevdir)"/rules.d
+               $(multilib_native_use_enable vala)
+               "$(systemd_with_unitdir)"
+       )
+
+       if ! multilib_is_native_abi; then
+               # disable some extraneous checks
+               myconf+=(
+                       SQLITE_{CFLAGS,LIBS}=' '
+                       GUDEV_{CFLAGS,LIBS}=' '
+               )
+       fi
+
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+       if multilib_is_native_abi; then
+               gnome2_src_compile
+       else
+               emake -C lib/colord
+               use gusb && emake -C lib/colorhug
+               emake -C lib/compat
+       fi
+}
+
+multilib_src_test() {
+       if multilib_is_native_abi; then
+               default
+       else
+               emake -C lib/colord check
+               use gusb && emake -C lib/colorhug check
+               emake -C lib/compat check
+       fi
+}
+
+multilib_src_install() {
+       if multilib_is_native_abi; then
+               gnome2_src_install
+       else
+               gnome2_src_install -C lib/colord
+               use gusb && gnome2_src_install -C lib/colorhug
+               gnome2_src_install -C lib/compat
+               gnome2_src_install -C contrib/session-helper install-libcolord_includeHEADERS
+       fi
+}
+
+multilib_src_install_all() {
+       DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README.md TODO"
+       einstalldocs
+
+       newbashcomp data/colormgr colormgr
+
+       # Ensure config and profile directories exist and /var/lib/colord/*
+       # is writable by colord user
+       keepdir /var/lib/color{,d}/icc
+       fowners colord:colord /var/lib/colord{,/icc}
+
+       if use examples; then
+               docinto examples
+               dodoc examples/*.c
+       fi
+}