app-crypt/debian-archive-keyring: Fix compilation (bug #614932)
authorSebastian Pipping <sping@gentoo.org>
Sat, 8 Apr 2017 16:03:46 +0000 (18:03 +0200)
committerSebastian Pipping <sping@gentoo.org>
Sat, 8 Apr 2017 16:04:25 +0000 (18:04 +0200)
Thanks to Toralf Foerster

Package-Manager: Portage-2.3.5, Repoman-2.3.2

app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild
app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch [new file with mode: 0644]

index b0acabf6bc8a30b65f03858ffd2adcd619c82746..fde180a215f92f32a8d5b54c1f46633169d1f6c2 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
 DESCRIPTION="GnuPG archive keys of the Debian archive"
 HOMEPAGE="http://packages.debian.org/sid/debian-archive-keyring"
@@ -15,3 +15,7 @@ IUSE=""
 DEPEND="app-crypt/jetring"
 
 MAKEOPTS+=' -j1'
+
+PATCHES=(
+       "${FILESDIR}"/${P}-order.patch
+)
diff --git a/app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch b/app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch
new file mode 100644 (file)
index 0000000..59b2412
--- /dev/null
@@ -0,0 +1,36 @@
+From fdf28f2cb17ae0bf8fac569335dabdbc9e83a452 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 8 Apr 2017 14:55:06 +0200
+Subject: [PATCH] Ensure verification starts after build
+
+---
+ Makefile | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0952a5d..b722226 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,12 @@ TMPRING := trusted.gpg/build-area
+ GPG_OPTIONS := --no-options --no-default-keyring --no-auto-check-trustdb --trustdb-name ./trustdb.gpg
+-build: verify-indices keyrings/debian-archive-keyring.gpg keyrings/debian-archive-removed-keys.gpg verify-results $(TRUSTED-LIST)
++all:
++      $(MAKE) build verify
++
++build: keyrings/debian-archive-keyring.gpg keyrings/debian-archive-removed-keys.gpg $(TRUSTED-LIST)
++
++verify: verify-indices verify-results
+ verify-indices: keyrings/team-members.gpg
+       gpg ${GPG_OPTIONS} \
+@@ -61,4 +66,4 @@ install: build
+       install -d $(DESTDIR)/etc/apt/trusted.gpg.d/
+       cp $(shell find trusted.gpg/ -name '*.gpg' -type f) $(DESTDIR)/etc/apt/trusted.gpg.d/
+-.PHONY: verify-indices verify-results clean build install
++.PHONY: all verify verify-indices verify-results clean build install
+-- 
+2.12.2
+