sci-physics/geant-vmc: new package.
authorOliver Freyermuth <o.freyermuth@googlemail.com>
Mon, 5 Feb 2018 23:17:42 +0000 (00:17 +0100)
committerGuilherme Amadio <amadio@gentoo.org>
Thu, 23 Aug 2018 14:18:16 +0000 (16:18 +0200)
Geant4 VMC represents the realisation of the
Virtual Monte Carlo (VMC) for Geant4.

Package-Manager: Portage-2.3.24, Repoman-2.3.6
RepoMan-Options: --force

sci-physics/geant-vmc/Manifest [new file with mode: 0644]
sci-physics/geant-vmc/geant-vmc-4.3.6.ebuild [new file with mode: 0644]
sci-physics/geant-vmc/geant-vmc-9999.ebuild [new file with mode: 0644]
sci-physics/geant-vmc/metadata.xml [new file with mode: 0644]

diff --git a/sci-physics/geant-vmc/Manifest b/sci-physics/geant-vmc/Manifest
new file mode 100644 (file)
index 0000000..0bd6fad
--- /dev/null
@@ -0,0 +1 @@
+DIST geant4_vmc.3.6.tar.gz 1017407 BLAKE2B f386ea49843abedbed16ba1d12a10ae4165123fb0f7842482c416becf4141bc15360be1038626ce40f96a9dbb15d27116cd2fbd46d74b856d5a9391d073784a5 SHA512 eaf8626a3702149a1c5be4adff7843ef828da8024aafb8de489dd6b55b4ee05850581318d01032a4008767ad4e2fc0fde23e1aa5c751693e902d51ce9ad3d1df
diff --git a/sci-physics/geant-vmc/geant-vmc-4.3.6.ebuild b/sci-physics/geant-vmc/geant-vmc-4.3.6.ebuild
new file mode 100644 (file)
index 0000000..2156a04
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/vmc-project/geant4_vmc.git"
+else
+       DOWN_PV=$(ver_cut 2-)
+       SRC_URI="http://root.cern.ch/download/vmc/geant4_vmc.${DOWN_PV}.tar.gz"
+       SOURCE_PV=$(ver_rs 1- - ${DOWN_PV})
+       S="${WORKDIR}/geant4_vmc-${SOURCE_PV}"
+       KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="http://root.cern.ch/root/vmc/VirtualMC.html"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="doc examples geant3 +g4root +mtroot vgm test"
+
+# sci-physics/root[root7] flag activates std=c++14, which we could only support if also Geant is built with it.
+# Disable for now.
+RDEPEND="
+       >=sci-physics/geant-4.10.03:=[opengl,geant3?]
+       sci-physics/root:=[-root7]
+       vgm? ( >=sci-physics/vgm-4.4:= )"
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen )"
+RESTRICT="
+       !geant3? ( test )
+       !g4root? ( test )
+       !mtroot? ( test )
+       !vgm? ( test )"
+
+DOCS=(
+       history
+       README.md
+)
+
+src_configure() {
+       local mycmakeargs=(
+               -DGeant4VMC_USE_VGM="$(usex vgm)"
+               -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+               -DGeant4VMC_USE_G4Root="$(usex g4root)"
+               -DGeant4VMC_BUILD_MTRoot="$(usex mtroot)"
+               -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+               -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+       )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+       if use doc ; then
+               local dirs=(
+                       source
+                       $(usev g4root)
+                       $(usev mtroot)
+                       $(usev examples)
+               )
+               local d
+               for d in "${dirs[@]}"; do
+                       pushd "${d}" > /dev/null || die
+                       doxygen || die
+                       popd > /dev/null || die
+               done
+       fi
+}
+
+src_test() {
+       # Required by sci-physics/root for pointer validity checking,
+       # see e.g. https://sft.its.cern.ch/jira/browse/ROOT-8146 .
+       addwrite /dev/random
+       cd examples || die
+       ./test_suite.sh --g3=off --builddir="${BUILD_DIR}" || die
+       ./test_suite_exe.sh --g3=off --builddir="${BUILD_DIR}" || die
+}
+
+src_install() {
+       cmake-utils_src_install
+       use doc && local HTML_DOCS=(doc/.)
+       einstalldocs
+}
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
new file mode 100644 (file)
index 0000000..2156a04
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/vmc-project/geant4_vmc.git"
+else
+       DOWN_PV=$(ver_cut 2-)
+       SRC_URI="http://root.cern.ch/download/vmc/geant4_vmc.${DOWN_PV}.tar.gz"
+       SOURCE_PV=$(ver_rs 1- - ${DOWN_PV})
+       S="${WORKDIR}/geant4_vmc-${SOURCE_PV}"
+       KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="http://root.cern.ch/root/vmc/VirtualMC.html"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="doc examples geant3 +g4root +mtroot vgm test"
+
+# sci-physics/root[root7] flag activates std=c++14, which we could only support if also Geant is built with it.
+# Disable for now.
+RDEPEND="
+       >=sci-physics/geant-4.10.03:=[opengl,geant3?]
+       sci-physics/root:=[-root7]
+       vgm? ( >=sci-physics/vgm-4.4:= )"
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen )"
+RESTRICT="
+       !geant3? ( test )
+       !g4root? ( test )
+       !mtroot? ( test )
+       !vgm? ( test )"
+
+DOCS=(
+       history
+       README.md
+)
+
+src_configure() {
+       local mycmakeargs=(
+               -DGeant4VMC_USE_VGM="$(usex vgm)"
+               -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+               -DGeant4VMC_USE_G4Root="$(usex g4root)"
+               -DGeant4VMC_BUILD_MTRoot="$(usex mtroot)"
+               -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+               -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+       )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+       if use doc ; then
+               local dirs=(
+                       source
+                       $(usev g4root)
+                       $(usev mtroot)
+                       $(usev examples)
+               )
+               local d
+               for d in "${dirs[@]}"; do
+                       pushd "${d}" > /dev/null || die
+                       doxygen || die
+                       popd > /dev/null || die
+               done
+       fi
+}
+
+src_test() {
+       # Required by sci-physics/root for pointer validity checking,
+       # see e.g. https://sft.its.cern.ch/jira/browse/ROOT-8146 .
+       addwrite /dev/random
+       cd examples || die
+       ./test_suite.sh --g3=off --builddir="${BUILD_DIR}" || die
+       ./test_suite_exe.sh --g3=off --builddir="${BUILD_DIR}" || die
+}
+
+src_install() {
+       cmake-utils_src_install
+       use doc && local HTML_DOCS=(doc/.)
+       einstalldocs
+}
diff --git a/sci-physics/geant-vmc/metadata.xml b/sci-physics/geant-vmc/metadata.xml
new file mode 100644 (file)
index 0000000..ef4bdfb
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>o.freyermuth@googlemail.com</email>
+    <name>Oliver Freyermuth</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">vmc-project/geant4_vmc</remote-id>
+  </upstream>
+  <use>
+    <flag name="vgm">Enable the Virtual Geometry Model (<pkg>sci-physics/vgm</pkg>)</flag>
+    <flag name="g4root">Build G4Root (interface for GEANT4 simulation with a ROOT geometry)</flag>
+    <flag name="geant3">Build with Geant4 G3toG4 library</flag>
+    <flag name="mtroot">Build MTRoot (provides ROOT IO manager classes with multi-threading support)</flag>
+  </use>
+</pkgmetadata>