kde-base/kdeplasma-addons: Drop Nepomuk support
authorJohannes Huber <johu@gentoo.org>
Wed, 12 Aug 2015 21:41:21 +0000 (23:41 +0200)
committerJohannes Huber <johu@gentoo.org>
Wed, 12 Aug 2015 22:03:31 +0000 (00:03 +0200)
Package-Manager: portage-2.2.20.1

kde-base/kdeplasma-addons/kdeplasma-addons-4.14.3.ebuild
kde-base/kdeplasma-addons/metadata.xml

index 2ee2f266ae60f67a74e959a9bdd4cbd4e399447d..aeee82b363f9b71ede9418517c84d4c2671a3fd9 100644 (file)
@@ -9,8 +9,8 @@ inherit kde4-base
 DESCRIPTION="Extra Plasma applets and engines"
 LICENSE="GPL-2 LGPL-2"
 KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="attica debug desktopglobe exif fcitx ibus json +kdepim nepomuk oauth
-qalculate qwt scim"
+IUSE="attica debug desktopglobe exif fcitx ibus json +kdepim oauth qalculate
+qwt scim"
 
 RESTRICT=test
 # tests hang
@@ -18,9 +18,8 @@ RESTRICT=test
 # krunner is only needed to generate dbus interface for lancelot
 COMMON_DEPEND="
        app-crypt/qca:2[qt4(+)]
-       $(add_kdebase_dep kdelibs 'nepomuk?')
        $(add_kdebase_dep krunner '' 4.11)
-       $(add_kdebase_dep plasma-workspace 'nepomuk?' 4.11)
+       $(add_kdebase_dep plasma-workspace '' 4.11)
        x11-misc/shared-mime-info
        attica? ( dev-libs/libattica )
        desktopglobe? ( $(add_kdeapps_dep marble) )
@@ -44,13 +43,13 @@ RDEPEND="${COMMON_DEPEND}
 src_configure() {
        local mycmakeargs=(
                -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+               -DWITH_Nepomuk=OFF
                $(cmake-utils_use_with attica LibAttica)
                $(cmake-utils_use_with desktopglobe Marble)
                $(cmake-utils_use_with exif Kexiv2)
                $(cmake-utils_use_build ibus)
                $(cmake-utils_use_with json QJSON)
                $(cmake-utils_use_with kdepim KdepimLibs)
-               $(cmake-utils_use_with nepomuk)
                $(cmake-utils_use_with oauth QtOAuth)
                $(cmake-utils_use_with qalculate)
                $(cmake-utils_use_with qwt)
index f465b65cadf2397500749fa382e060e057eb8650..4798f1b45e7feebea6820e04c883ce75ea199d92 100644 (file)
@@ -9,7 +9,6 @@
                <flag name="fcitx">Use fcitx input method via <pkg>app-i18n/fcitx</pkg></flag>
                <flag name="json">Enable JSON support via <pkg>dev-libs/qjson</pkg></flag>
                <flag name="kdepim">KDE PIM integration via <pkg>kde-base/kdepimlibs</pkg></flag>
-               <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
                <flag name="oauth">Enable OAuth support via <pkg>dev-libs/qoauth</pkg></flag>
                <flag name="qalculate">Enable Qalculate runner using <pkg>sci-libs/libqalculate</pkg></flag>
                <flag name="qwt">Enable applets that use <pkg>x11-libs/qwt:5</pkg></flag>