app-text/ttf2pk2: Fix building with GCC 10
authorDavid Seifert <soap@gentoo.org>
Fri, 7 Feb 2020 09:58:53 +0000 (10:58 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 7 Feb 2020 09:58:53 +0000 (10:58 +0100)
Closes: https://bugs.gentoo.org/707294
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
app-text/ttf2pk2/files/ttf2pk2-2.0_p20190410-fno-common-gcc10.patch [new file with mode: 0644]
app-text/ttf2pk2/ttf2pk2-2.0_p20190410.ebuild

diff --git a/app-text/ttf2pk2/files/ttf2pk2-2.0_p20190410-fno-common-gcc10.patch b/app-text/ttf2pk2/files/ttf2pk2-2.0_p20190410-fno-common-gcc10.patch
new file mode 100644 (file)
index 0000000..7467820
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/pklib.c
++++ b/pklib.c
+@@ -64,8 +64,6 @@
+ #define PK_POST (char)245
+ #define PK_NOP  (char)246
+-int dpi;
+-
+ FILE *pk_file;
+--- a/pklib.h
++++ b/pklib.h
+@@ -13,6 +13,7 @@
+ typedef unsigned char byte;
++extern int dpi;
+ void TFMopen(char **filename);
index 6499ac50b3ec795d04154157cc3687c1bdda7e2a..6528f2d15c053aca6e53938b1d24ef4a2ed0fba7 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -28,6 +28,8 @@ BDEPEND="virtual/pkgconfig"
 
 S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
 
+PATCHES=( "${FILESDIR}"/${PN}-2.0_p20190410-fno-common-gcc10.patch )
+
 src_configure() {
        econf --with-system-kpathsea \
                --with-system-freetype2 \