games-kids/gcompris: 0.97 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 09:59:32 +0000 (10:59 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 12:04:02 +0000 (13:04 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
games-kids/gcompris/Manifest
games-kids/gcompris/gcompris-0.97.ebuild [new file with mode: 0644]
games-kids/gcompris/metadata.xml

index 7d01c5bb3d7b5a28dc319ee7e227e264d6aa0a9b..35a7333c05cbb64d2c1209abdeda9ca03d7d3d73 100644 (file)
@@ -1 +1,2 @@
 DIST gcompris-qt-0.96.tar.xz 73221940 BLAKE2B e6d81d1630d962709a1ab27c8735ac42ce67182440f3e78a7d3f39b59b28617211dddf3f6d62a323ee5af7f147e2dc784ff0b305bee7b345d1e59d3ed576ef1a SHA512 980bac743d786d3b35c28cec90bd785d568177c9299f5460918124d111565609fbcd35ec76412776151f6fe12ba9ab3efc77bc5cb05895e54dc7822f9862214c
+DIST gcompris-qt-0.97.tar.xz 75362060 BLAKE2B e6bc429ba4a8a622792935c9b2e68149f5c1f4d9aae4cac84ca517ebe83e59a9b4307f6ce84b36e658256cad5c8bd37b7cbc60a058b6d65be372ad1934cf666f SHA512 23cc807238121a6ea3abb8816795b2f3b243c3be1acf782705468d92758a2032a8cb5393c3c30028877d174ff53ebc3a62f69e9045bc70a5281d1d245b6e4eba
diff --git a/games-kids/gcompris/gcompris-0.97.ebuild b/games-kids/gcompris/gcompris-0.97.ebuild
new file mode 100644 (file)
index 0000000..2131874
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Full featured educational application for children from 2 to 10"
+HOMEPAGE="https://gcompris.net/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+       SRC_URI="https://gcompris.net/download/qt/src/${PN}-qt-${PV}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/${PN}-qt-${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="kiosk"
+
+BDEPEND="
+       >=dev-qt/linguist-tools-${QTMIN}:5
+       test? (
+               dev-util/cppcheck
+               sys-devel/clang
+       )
+"
+RDEPEND="
+       >=dev-qt/qtdeclarative-${QTMIN}:5
+       >=dev-qt/qtgui-${QTMIN}:5
+       >=dev-qt/qtnetwork-${QTMIN}:5
+       >=dev-qt/qtsensors-${QTMIN}:5
+       >=dev-qt/qtsvg-${QTMIN}:5
+"
+DEPEND="${RDEPEND}
+       >=dev-qt/qtmultimedia-${QTMIN}:5
+       >=dev-qt/qtxml-${QTMIN}:5
+       >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+
+src_configure() {
+       local mycmakeargs=(
+               -DQML_BOX2D_MODULE=disabled
+               -DWITH_KIOSK_MODE=$(usex kiosk)
+       )
+       ecm_src_configure
+}
index 713d7d0e6cc16cce6bad18597cecb37ba34ad2f2..ab0bc780ada989e3e0c4ada23fbe2d8bb25a59e3 100644 (file)
@@ -3,10 +3,13 @@
 <pkgmetadata>
        <maintainer type="project">
                <email>kde@gentoo.org</email>
-               <name>Gentoo Games Project</name>
+               <name>Gentoo KDE Project</name>
        </maintainer>
        <maintainer type="project">
                <email>games@gentoo.org</email>
                <name>Gentoo Games Project</name>
        </maintainer>
+       <use>
+               <flag name="kiosk">Enable kiosk mode by default (for use by small children or on a self-service host machine)</flag>
+       </use>
 </pkgmetadata>