dev-perl/Tie-Cache: EAPI6 + tests + QA
authorKent Fredric <kentnl@gentoo.org>
Thu, 15 Mar 2018 08:47:50 +0000 (21:47 +1300)
committerKent Fredric <kentnl@gentoo.org>
Thu, 15 Mar 2018 08:49:50 +0000 (21:49 +1300)
- EAPI6ify
- Add USE='examples'
- Enable tests
- Prevent benchmark example being installed by default

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/Tie-Cache/Tie-Cache-0.210.0-r1.ebuild [new file with mode: 0644]
dev-perl/Tie-Cache/files/Tie-Cache-0.21-benchmark.patch [new file with mode: 0644]

diff --git a/dev-perl/Tie-Cache/Tie-Cache-0.210.0-r1.ebuild b/dev-perl/Tie-Cache/Tie-Cache-0.210.0-r1.ebuild
new file mode 100644 (file)
index 0000000..a5ac639
--- /dev/null
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CHAMAS
+DIST_VERSION=0.21
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="In memory size limited LRU cache"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+PATCHES=("${FILESDIR}/${PN}-0.21-benchmark.patch")
diff --git a/dev-perl/Tie-Cache/files/Tie-Cache-0.21-benchmark.patch b/dev-perl/Tie-Cache/files/Tie-Cache-0.21-benchmark.patch
new file mode 100644 (file)
index 0000000..a1dc7ae
--- /dev/null
@@ -0,0 +1,32 @@
+From 426687ca37129637676a4a63667b5b060548800b Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 15 Mar 2018 21:39:27 +1300
+Subject: Relocate benchmark script to avoid default installation
+
+As *.pl deploys to $INC[0]/Tie/*.pl  due to "foo.pl" being a legacy
+"perl library"
+---
+ MANIFEST                                          | 2 +-
+ tie-cache-bench.pl => examples/tie-cache-bench.pl | 0
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+ rename tie-cache-bench.pl => examples/tie-cache-bench.pl (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index 67ea1da..ae66cae 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -5,6 +5,6 @@ MANIFEST.SKIP
+ MANIFEST.bak
+ Makefile.PL
+ README
+-tie-cache-bench.pl
++examples/tie-cache-bench.pl
+ test.pl
+ META.yml                                 Module meta-data (added by MakeMaker)
+diff --git a/tie-cache-bench.pl b/examples/tie-cache-bench.pl
+similarity index 100%
+rename from tie-cache-bench.pl
+rename to examples/tie-cache-bench.pl
+-- 
+2.16.2
+