dev-lang/php: Use relative symlinks; whitespace
authorBrian Evans <grknight@gentoo.org>
Tue, 3 Mar 2020 20:03:41 +0000 (15:03 -0500)
committerBrian Evans <grknight@gentoo.org>
Tue, 3 Mar 2020 20:03:41 +0000 (15:03 -0500)
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-lang/php/php-7.2.28-r1.ebuild
dev-lang/php/php-7.3.15-r1.ebuild
dev-lang/php/php-7.4.3-r1.ebuild

index 96047b4e667727ee2349ff5e0ccc77817695319e..e032d1b3af008e582ebaac616f61891d0d5c210c 100644 (file)
@@ -557,11 +557,11 @@ src_install() {
                                case "$sapi" in
                                        cli)
                                                source="sapi/cli/php"
-                                                # Install the "phar" archive utility.
-                                                if use phar ; then
-                                                        emake INSTALL_ROOT="${D}" install-pharcmd
-                                                        dosym "${dest}/bin/phar" "/usr/bin/phar${SLOT}"
-                                                fi
+                                               # Install the "phar" archive utility.
+                                               if use phar ; then
+                                                       emake INSTALL_ROOT="${D}" install-pharcmd
+                                                       dosym "..${dest#/usr}/bin/phar" "/usr/bin/phar${SLOT}"
+                                               fi
                                                ;;
                                        cgi)
                                                source="sapi/cgi/php-cgi"
@@ -585,7 +585,7 @@ src_install() {
                                else
                                        dobin "${source}"
                                        local name="$(basename ${source})"
-                                       dosym "${dest}/bin/${name}" "/usr/bin/${name}${SLOT}"
+                                       dosym "..${dest#/usr}/bin/${name}" "/usr/bin/${name}${SLOT}"
                                fi
                        fi
 
index 1726c6222789fb30efe04a3e41ff3e94e2b11d94..75ec441d1c320f25ee3379e39e1feef7be344d18 100644 (file)
@@ -558,11 +558,11 @@ src_install() {
                                case "$sapi" in
                                        cli)
                                                source="sapi/cli/php"
-                                                # Install the "phar" archive utility.
-                                                if use phar ; then
-                                                        emake INSTALL_ROOT="${D}" install-pharcmd
-                                                        dosym "${dest}/bin/phar" "/usr/bin/phar${SLOT}"
-                                                fi
+                                               # Install the "phar" archive utility.
+                                               if use phar ; then
+                                                       emake INSTALL_ROOT="${D}" install-pharcmd
+                                                       dosym "..${dest#/usr}/bin/phar" "/usr/bin/phar${SLOT}"
+                                               fi
                                                ;;
                                        cgi)
                                                source="sapi/cgi/php-cgi"
@@ -586,7 +586,7 @@ src_install() {
                                else
                                        dobin "${source}"
                                        local name="$(basename ${source})"
-                                       dosym "${dest}/bin/${name}" "/usr/bin/${name}${SLOT}"
+                                       dosym "..${dest#/usr}/bin/${name}" "/usr/bin/${name}${SLOT}"
                                fi
                        fi
 
index 3701941e244017f870d41b9b458b66e10581a7fe..f2c76031d7de5e50bf49bd7d177357a62539f2fa 100644 (file)
@@ -551,7 +551,7 @@ src_install() {
                                                # Install the "phar" archive utility.
                                                if use phar ; then
                                                        emake INSTALL_ROOT="${D}" install-pharcmd
-                                                       dosym "${dest}/bin/phar" "/usr/bin/phar${SLOT}"
+                                                       dosym "..${dest#/usr}/bin/phar" "/usr/bin/phar${SLOT}"
                                                fi
                                                ;;
                                        cgi)
@@ -576,7 +576,7 @@ src_install() {
                                else
                                        dobin "${source}"
                                        local name="$(basename ${source})"
-                                       dosym "${dest}/bin/${name}" "/usr/bin/${name}${SLOT}"
+                                       dosym "..${dest#/usr}/bin/${name}" "/usr/bin/${name}${SLOT}"
                                fi
                        fi