dev-python/matplotlib: Bump to version 3.2.1
authorVictor Payno <vpayno+gentoo@gmail.com>
Sun, 12 Apr 2020 06:26:10 +0000 (23:26 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Sun, 26 Apr 2020 03:11:48 +0000 (20:11 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15315
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/matplotlib/Manifest
dev-python/matplotlib/matplotlib-3.2.1.ebuild [new file with mode: 0644]

index 70225931856134d41be1adde05953348855f3538..92713a4049d89ba8db017a3de848d1d0a958863e 100644 (file)
@@ -1,3 +1,4 @@
 DIST matplotlib-2.2.2.tar.gz 37317332 BLAKE2B 4120265263c5b1e4ab57f7c0eb7a477b4071a5f219d1d6328d6ed51d44460217c7c4da82a4b7d13c6ba9f80308406a217f2dbcfa310f3137cbe8bc56a9ef0eef SHA512 1d21ef821190f22354098f8f0db6449f237acbf3c1419ab3815ecd4e9c6922fd3f00c4a8f60858e319b55b6fb2e8fe2922c0bf8e72b204e7edff0b409cf76320
 DIST matplotlib-2.2.4.tar.gz 36974286 BLAKE2B 9c4c69163a23ff02107ee155f72e142dcf31ba965f6a20f468b96f3f4b70b95ff6caade6b14bcbacd5b231848d2000ce6af9f113feefb41d6e186725349490d3 SHA512 968f5731b8a9a2c5575403c60d5b0a98a452b33094e520be44f4d901f892d082babc8fc1d73c519e1ff2baf756f3cb7652f4b796e166d66dfda31f7e50c58139
 DIST matplotlib-3.1.2.tar.gz 40909582 BLAKE2B 670907670335ca13ec01f3acf036fd502ce34abd12666b2e0d10867c6115a0fe80039326cee89099471aa6b3bbd25f1ca4aa837072dea624ee41984da9f647be SHA512 2eff3c0525d01824ed758a87f50a3f6094767b580fca1eae4e9dbc2cc972af3d0cc3ac9615e576c5685e8bfc1ec90754bc826635f4f2a919d0b26bbb686cccab
+DIST matplotlib-3.2.1.tar.gz 40325615 BLAKE2B 7fd299f7d3948987e341e4313ed82d15de286a05c9819893e099ccd6c1f861ce5548ec85588a382603011e7710d08d6fc9a4f168f0b5705b0873b97e40d2dd39 SHA512 d6497a3c47eaff9c0d981bc03de5894a3f4a5413cbe320924b1df6d68eb421e548cf4247c035fd636a4403cd2d50071633e6906e795b74ec7d9c4816193e42be
diff --git a/dev-python/matplotlib/matplotlib-3.2.1.ebuild b/dev-python/matplotlib/matplotlib-3.2.1.ebuild
new file mode 100644 (file)
index 0000000..c506ee1
--- /dev/null
@@ -0,0 +1,259 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
+
+DESCRIPTION="Pure python plotting library with matlab like syntax"
+HOMEPAGE="https://matplotlib.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+# Main license: matplotlib
+# Some modules: BSD
+# matplotlib/backends/qt4_editor: MIT
+# Fonts: BitstreamVera, OFL-1.1
+LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
+KEYWORDS="~amd64"
+IUSE="cairo doc excel examples gtk3 latex qt5 tk wxwidgets"
+
+REQUIRED_USE="
+       test? (
+               cairo latex qt5 tk wxwidgets gtk3
+       )
+"
+
+# internal copy of pycxx highly patched
+#      dev-python/pycxx
+
+RDEPEND="
+       >=dev-python/cycler-0.10.0-r1[${PYTHON_USEDEP}]
+       >=dev-python/kiwisolver-1.2.0[${PYTHON_USEDEP}]
+       >=dev-python/numpy-1.18.2[${PYTHON_USEDEP}]
+       >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
+       dev-python/python-dateutil:0[${PYTHON_USEDEP}]
+       >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+       >=dev-python/six-1.14.0[${PYTHON_USEDEP}]
+       dev-python/versioneer[${PYTHON_USEDEP}]
+       media-fonts/dejavu
+       media-fonts/stix-fonts
+       media-libs/freetype:2
+       media-libs/libpng:0
+       >=media-libs/qhull-2013
+       >=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
+       cairo? (
+               dev-python/cairocffi[${PYTHON_USEDEP}]
+       )
+       excel? (
+               dev-python/xlwt[${PYTHON_USEDEP}]
+       )
+       gtk3? (
+               dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
+               x11-libs/gtk+:3[introspection]
+       )
+       latex? (
+               virtual/latex-base
+               app-text/dvipng
+               app-text/ghostscript-gpl
+               app-text/poppler[utils]
+               dev-texlive/texlive-fontsrecommended
+               dev-texlive/texlive-latexextra
+               dev-texlive/texlive-xetex
+       )
+       qt5? (
+               dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+       )
+       wxwidgets? (
+               dev-python/wxpython:*[${PYTHON_USEDEP}]
+       )
+"
+
+BDEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig
+       doc? (
+               >=app-text/dvipng-1.15-r1
+               >=dev-python/colorspacious-1.1.2[${PYTHON_USEDEP}]
+               >=dev-python/pillow-7.1.1[${PYTHON_USEDEP}]
+               >=dev-python/ipython-1.18.2[${PYTHON_USEDEP}]
+               >=dev-python/numpydoc-0.9.2[${PYTHON_USEDEP}]
+               >=sci-libs/scipy-1.4.1[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-gallery-0.3.1-r1[${PYTHON_USEDEP}]
+               >=dev-python/xlwt-1.3.0-r1[${PYTHON_USEDEP}]
+               dev-texlive/texlive-latexextra
+               dev-texlive/texlive-fontsrecommended
+               dev-texlive/texlive-latexrecommended
+               >=media-gfx/graphviz-2.42.3[cairo]
+       )
+       test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+# A few C++ source files are written to srcdir.
+# Other than that, the ebuild shall be fit for out-of-source build.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+distutils_enable_tests nose
+
+pkg_setup() {
+       unset DISPLAY # bug #278524
+}
+
+use_setup() {
+       local uword="${2:-${1}}"
+       if use ${1}; then
+               echo "${uword} = True"
+               echo "${uword}agg = True"
+       else
+               echo "${uword} = False"
+               echo "${uword}agg = False"
+       fi
+}
+
+python_prepare_all() {
+# Generates test failures, but fedora does it
+#      local PATCHES=(
+#              "${FILESDIR}"/${P}-unbundle-pycxx.patch
+#              "${FILESDIR}"/${P}-unbundle-agg.patch
+#      )
+#      rm -r agg24 CXX || die
+#      rm -r agg24 || die
+
+#      cat > lib/${PN}/externals/six.py <<-EOF
+#      from __future__ import absolute_import
+#      from six import *
+#      EOF
+
+       local PATCHES=(
+               "${FILESDIR}"/${PN}-3.1.2-qhull.patch
+       )
+
+       sed \
+               -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
+               -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
+               || die "sed pyparsing failed"
+
+       hprefixify setupext.py
+
+       rm -rf libqhull || die
+
+       export XDG_RUNTIME_DIR="${T}/runtime-dir"
+       mkdir "${XDG_RUNTIME_DIR}" || die
+       chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+       local freetype_version
+       freetype_version="$(best_version media-libs/freetype | sed -r -e 's/.*-([0-9].*[0-9])(-r[0-9]+|$)/\1/g')"
+       sed -i -r -e "s:(LOCAL_FREETYPE_VERSION =).*:\\1 \"${freetype_version}\":g" setupext.py lib/matplotlib/__init__.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+       append-flags -fno-strict-aliasing
+       append-cppflags -DNDEBUG  # or get old trying to do triangulation
+       tc-export PKG_CONFIG
+}
+
+python_configure() {
+       mkdir -p "${BUILD_DIR}" || die
+
+       # create setup.cfg (see setup.cfg.template for any changes).
+
+       # common switches.
+       cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
+               [directories]
+               basedirlist = ${EPREFIX}/usr
+               [provide_packages]
+               pytz = False
+               dateutil = False
+               [packages]
+               tests = $(usex test True False)
+               [gui_support]
+               agg = True
+               pyside = False
+               pysideagg = False
+               qt4 = False
+               qt4agg = False
+               $(use_setup cairo)
+               $(use_setup gtk3)
+               $(use_setup qt5)
+               $(use_setup tk)
+       EOF
+
+       if use gtk3 && use cairo; then
+               echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
+       else
+               echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
+       fi
+
+       if python_is_python3; then
+               cat >> "${BUILD_DIR}"/setup.cfg <<- EOF || die
+                       gtk = False
+                       gtkagg = False
+                       wx = False
+                       wxagg = False
+               EOF
+       else
+               cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
+                       $(use_setup gtk2 gtk)
+                       $(use_setup wxwidgets wx)
+               EOF
+       fi
+}
+
+wrap_setup() {
+       local MAKEOPTS=-j1
+       local -x MPLSETUPCFG="${BUILD_DIR}"/setup.cfg
+       unset DISPLAY
+       "$@"
+}
+
+python_compile() {
+       wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
+}
+
+python_compile_all() {
+       if use doc; then
+               cd doc || die
+
+               # necessary for in-source build
+               local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
+
+               VARTEXFONTS="${T}"/fonts \
+               emake SPHINXOPTS= O=-Dplot_formats=png:100 html
+       fi
+}
+
+python_test() {
+       wrap_setup distutils_install_for_testing
+
+       distutils_install_for_testing
+       "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)" || die
+}
+
+python_install() {
+       wrap_setup distutils-r1_python_install
+
+       # mpl_toolkits namespace
+       python_moduleinto mpl_toolkits
+       python_domodule lib/mpl_toolkits/__init__.py
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+
+       distutils-r1_python_install_all
+
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
+       find "${D}" -name '*.pth' -delete || die
+}