Version bump. bug# 78517 Thanks for patches Jacob Smullyan <smulloni@smullyan.org...
authorRob Cakebread <pythonhead@gentoo.org>
Thu, 20 Jan 2005 03:56:58 +0000 (03:56 +0000)
committerRob Cakebread <pythonhead@gentoo.org>
Thu, 20 Jan 2005 03:56:58 +0000 (03:56 +0000)
Package-Manager: portage-2.0.51-r14

dev-python/4suite/4suite-1.0_alpha3.ebuild
dev-python/4suite/4suite-1.0_alpha4.ebuild [new file with mode: 0644]
dev-python/4suite/ChangeLog
dev-python/4suite/Manifest
dev-python/4suite/files/digest-4suite-1.0_alpha4 [new file with mode: 0644]

index 28f4397a85dccdf974f6d4e2df75ade06a3b3e3e..e0c5c5d943dbd53f41e10280bf639fb276485749 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_alpha3.ebuild,v 1.8 2004/07/04 09:55:02 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_alpha3.ebuild,v 1.9 2005/01/20 03:56:58 pythonhead Exp $
 
 inherit distutils
 
diff --git a/dev-python/4suite/4suite-1.0_alpha4.ebuild b/dev-python/4suite/4suite-1.0_alpha4.ebuild
new file mode 100644 (file)
index 0000000..5d6f160
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_alpha4.ebuild,v 1.1 2005/01/20 03:56:58 pythonhead Exp $
+
+inherit distutils eutils
+
+MY_P=${P/_alpha/a}
+MY_P=${MY_P/4s/4S}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Python tools for XML processing and object-databases."
+SRC_URI="mirror://sourceforge/foursuite/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.4suite.org/"
+
+DEPEND=">=dev-lang/python-2.3
+       >=dev-python/pyxml-0.8.3"
+
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="Apache-1.1"
+
+PYTHON_MODNAME="Ft"
+DOCS="docs/*.txt"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       epatch ${FILESDIR}/4S-1.0_a4.addrootopt-gentoo.diff
+       python setup.py config --prefix=/usr --docdir=/usr/share/doc/${P}
+}
+
+src_install() {
+       if use doc; then
+               distutils_src_install --with-docs
+               else
+               distutils_src_install
+       fi
+}
index 0bfa51e49b223dc4211c5d2003fea9b2432056a2..0ba06f8e11979b77987a6c9ae6e3f0a19c16b62f 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-python/4suite
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.11 2004/12/30 21:05:11 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.12 2005/01/20 03:56:58 pythonhead Exp $
+
+*4suite-1.0_alpha4 (19 Jan 2005)
+
+  19 Jan 2005; Rob Cakebread <pythonhead@gentoo.org>
+  +4suite-1.0_alpha4.ebuild:
+  Version bump. bug# 78517 Thanks for patches Jacob Smullyan
+  <smulloni@smullyan.org> and kutsya@gentoo.org
 
   30 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
   Change encoding to UTF-8 for GLEP 31 compliance
index 10b83d0f24165baa382e40af32b44d10206cc8ab..05b1ca8ca868354132ed1e5f72502a85aee6eaa2 100644 (file)
@@ -1,4 +1,16 @@
-MD5 a7c35d0ef477d31d5502256859c7ac5d ChangeLog 2592
-MD5 167fd761ef2da6aab1dca11d47d33002 4suite-1.0_alpha3.ebuild 606
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e3c4022098e60ece3350df3430292634 4suite-1.0_alpha4.ebuild 916
+MD5 72aa6941a6afc35089f525c1f9658f83 4suite-1.0_alpha3.ebuild 610
+MD5 8b34b6adc07e98376b1e301b8c8b2bd6 ChangeLog 2821
 MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 880f1fc88e78283a8665b8b0e45b95de files/digest-4suite-1.0_alpha4 66
 MD5 0724d222f5540595a368fb7acd27c1f9 files/digest-4suite-1.0_alpha3 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFB7yw0z2gxt1z4IGYRAneVAJ9c5R6EaA8k6rww7j1ccT0kOF+hzQCgmv5b
+eVhGI8R6QU3TYC88S/p/3gc=
+=waOG
+-----END PGP SIGNATURE-----
diff --git a/dev-python/4suite/files/digest-4suite-1.0_alpha4 b/dev-python/4suite/files/digest-4suite-1.0_alpha4
new file mode 100644 (file)
index 0000000..3885f0e
--- /dev/null
@@ -0,0 +1 @@
+MD5 7a5de1ac3d336b7198b741be83d0722e 4Suite-1.0a4.tar.bz2 1764971