net-wireless/gr-ieee802154: add snapshot
authorZero_Chaos <zerochaos@gentoo.org>
Tue, 21 Aug 2018 17:23:15 +0000 (17:23 +0000)
committerZero_Chaos <zerochaos@gentoo.org>
Tue, 21 Aug 2018 17:23:33 +0000 (17:23 +0000)
minor updates, eapi bump, qa warning fix

Package-Manager: Portage-2.3.47, Repoman-2.3.10

net-wireless/gr-ieee802154/Manifest [new file with mode: 0644]
net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20180402.ebuild [new file with mode: 0644]
net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild

diff --git a/net-wireless/gr-ieee802154/Manifest b/net-wireless/gr-ieee802154/Manifest
new file mode 100644 (file)
index 0000000..1419ea0
--- /dev/null
@@ -0,0 +1 @@
+DIST gr-ieee802154-0.0_p20180402.tar.gz 195464 BLAKE2B 391bd4eefb5a90135a084a94c2edd83e6f2c2bd6dca26be4d9a54448382d5ee463e1740c305e9583be0107b424c67e74fac84ece147844e7c2a63f6096c7dd36 SHA512 90f164bdcd636dee68a49fe844901ca73e1f743fdeacd8019edddc57c681ec3d1fcfe209d8abd89e2013c2c2c436b7992fe0b0dbe9c88c04352aebc0813a9d96
diff --git a/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20180402.ebuild b/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20180402.ebuild
new file mode 100644 (file)
index 0000000..558bac5
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="IEEE 802.15.4 ZigBee Transceiver"
+HOMEPAGE="https://github.com/bastibl/gr-ieee802-15-4"
+
+if [[ ${PV} == 9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/bastibl/gr-ieee802-15-4.git"
+       KEYWORDS=""
+else
+       COMMIT="c969b3fd2059472a28dee6f911083dd03d1dd569"
+       SRC_URI="https://github.com/bastibl/gr-ieee802-15-4/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/gr-ieee802-15-4-${COMMIT}"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+
+RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+       dev-libs/boost:=[${PYTHON_USEDEP}]
+       ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+       dev-lang/swig:0"
+#cppunit is listed in cmake, but only needed for tests and there are no tests
+#      dev-util/cppunit"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+       #although cppunit is not used, it fails if it isn't there, fix it
+       sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
+       sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
+       sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+       cmake-utils_src_configure
+}
index d697f092a4dd249f73aedb7117fe55935190cb4d..558bac59bdce51e86772eac7d0d3f7200a6e7e74 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 PYTHON_COMPAT=( python2_7 )
 
 inherit cmake-utils python-single-r1
@@ -13,9 +13,11 @@ if [[ ${PV} == 9999* ]]; then
        inherit git-r3
        EGIT_REPO_URI="https://github.com/bastibl/gr-ieee802-15-4.git"
        KEYWORDS=""
-#else
-#      SRC_URI=""
-#      KEYWORDS=""
+else
+       COMMIT="c969b3fd2059472a28dee6f911083dd03d1dd569"
+       SRC_URI="https://github.com/bastibl/gr-ieee802-15-4/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/gr-ieee802-15-4-${COMMIT}"
+       KEYWORDS="~amd64 ~x86"
 fi
 
 LICENSE="GPL-3"
@@ -36,6 +38,7 @@ src_prepare() {
        sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
        sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
        sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+       cmake-utils_src_prepare
 }
 
 src_configure() {