media-libs/vulkan-layers: Bump to 1.1.125
authorNick Sarnie <sarnex@gentoo.org>
Sun, 27 Oct 2019 13:26:41 +0000 (09:26 -0400)
committerNick Sarnie <sarnex@gentoo.org>
Sun, 27 Oct 2019 13:26:41 +0000 (09:26 -0400)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
media-libs/vulkan-layers/Manifest
media-libs/vulkan-layers/vulkan-layers-1.1.125.ebuild [new file with mode: 0644]
media-libs/vulkan-layers/vulkan-layers-9999.ebuild

index 73acc6933d758838387f703c860e2687e78d88ff..86cbc25b4d673e06d2f2d8fba4513a3b6a87dbab 100644 (file)
@@ -1 +1,2 @@
 DIST vulkan-layers-1.1.106.tar.gz 1151285 BLAKE2B 763654d76c0c9d139ab922b2319df8becef5357c140ade3ba5d99cdbf6c7440b156048970202c2735bed4cb7de213d6647e492fa608023c91cf94a4b0353b4b9 SHA512 caf2c54c89aee2760747fc03f6d3e7742687f86aed5f05e1e8beffac35b114fd61af761bf95593f7cbdb3f9dbc92f570916af1225c7cdce3c16ba81024dc2027
+DIST vulkan-layers-1.1.125.tar.gz 1763589 BLAKE2B e6db1c8b2469afcc9565a55e3977443952cf8a176b6b2b2f5747fbfdb887074e014138b4626f58ddb5c24f87260af32c0c589aef237366aee5acfd3b31ad06ee SHA512 07fcfa9737711671a1a537285f69b63b1a14cf9201dcc169fbe99e19febe612ba8a1e7b448d18bfd01a35d90fb99a261ada0ae9b8facb36d04079bcf3c5c72e0
diff --git a/media-libs/vulkan-layers/vulkan-layers-1.1.125.ebuild b/media-libs/vulkan-layers/vulkan-layers-1.1.125.ebuild
new file mode 100644 (file)
index 0000000..468b7bd
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+if [[ "${PV}" == "9999" ]]; then
+       EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-ValidationLayers.git"
+       EGIT_SUBMODULES=()
+       inherit git-r3
+else
+       EGIT_COMMIT="237d818e81fbffa073d29d94f53a2cbac4f25b9f"
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/KhronosGroup/Vulkan-ValidationLayers/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/Vulkan-ValidationLayers-${EGIT_COMMIT}"
+fi
+
+inherit python-any-r1 cmake-multilib
+
+DESCRIPTION="Vulkan Validation Layers"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-ValidationLayers"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="X wayland"
+
+DEPEND="${PYTHON_DEPS}
+               >=dev-util/glslang-7.11.3114_pre20190415:=[${MULTILIB_USEDEP}]
+               >=dev-util/spirv-tools-2019.1-r1:=[${MULTILIB_USEDEP}]
+               >=dev-util/vulkan-headers-1.1.125
+               wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+               X? (
+                  x11-libs/libX11:=[${MULTILIB_USEDEP}]
+                  x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+                  )"
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_SKIP_RPATH=True
+               -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+               -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+               -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+               -DBUILD_TESTS=False
+               -DGLSLANG_INSTALL_DIR="/usr"
+               -DCMAKE_INSTALL_INCLUDEDIR="/usr/include/vulkan/"
+       )
+       cmake-utils_src_configure
+}
index 0858c0d8f89986ffe777746854501dcc2ce4caaa..468b7bd532a8c3b9912312ef9c32a160a6f7e883 100644 (file)
@@ -1,15 +1,15 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
 
 if [[ "${PV}" == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-ValidationLayers.git"
        EGIT_SUBMODULES=()
        inherit git-r3
 else
-       EGIT_COMMIT="89bbac497742d48c3d483f78b1bba99101784746"
+       EGIT_COMMIT="237d818e81fbffa073d29d94f53a2cbac4f25b9f"
        KEYWORDS="~amd64 ~x86"
        SRC_URI="https://github.com/KhronosGroup/Vulkan-ValidationLayers/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
        S="${WORKDIR}/Vulkan-ValidationLayers-${EGIT_COMMIT}"
@@ -27,7 +27,7 @@ IUSE="X wayland"
 DEPEND="${PYTHON_DEPS}
                >=dev-util/glslang-7.11.3114_pre20190415:=[${MULTILIB_USEDEP}]
                >=dev-util/spirv-tools-2019.1-r1:=[${MULTILIB_USEDEP}]
-               >=dev-util/vulkan-headers-1.1.106
+               >=dev-util/vulkan-headers-1.1.125
                wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
                X? (
                   x11-libs/libX11:=[${MULTILIB_USEDEP}]