dev-python/ipython_genutils: add python3_8
authorAndrey Grozin <grozin@gentoo.org>
Mon, 2 Mar 2020 15:06:54 +0000 (22:06 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Mon, 2 Mar 2020 15:06:54 +0000 (22:06 +0700)
Package-Manager: Portage-2.3.91, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild
new file mode 100644 (file)
index 0000000..9036c7d
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vestigial utilities from IPython"
+HOMEPAGE="https://github.com/ipython/ipython_genutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/coverage[${PYTHON_USEDEP}]
+       )
+       "
+
+python_test() {
+       nosetests --with-coverage --cover-package=ipython_genutils ipython_genutils || die
+}