net-analyzer/nmapsi: add patch fixing build with kde-base/kdelibs-4.14.11.
authorMichael Palimaka <kensington@gentoo.org>
Thu, 10 Sep 2015 12:50:33 +0000 (22:50 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Thu, 10 Sep 2015 12:50:50 +0000 (22:50 +1000)
Gentoo-bug: 558574

Package-Manager: portage-2.2.20.1

net-analyzer/nmapsi/files/nmapsi-0.4.1-kdelibs-4.14.11.patch [new file with mode: 0644]
net-analyzer/nmapsi/nmapsi-0.4.1.ebuild

diff --git a/net-analyzer/nmapsi/files/nmapsi-0.4.1-kdelibs-4.14.11.patch b/net-analyzer/nmapsi/files/nmapsi-0.4.1-kdelibs-4.14.11.patch
new file mode 100644 (file)
index 0000000..f5a338a
--- /dev/null
@@ -0,0 +1,22 @@
+The uninstall target is created automatically by FindKDE4Internal. Due to
+cmake policy changes in kdelibs-4.14.11, this target name collision causes
+a build failure.
+
+https://bugs.gentoo.org/show_bug.cgi?id=558574
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -35,13 +35,6 @@
+ add_subdirectory( src )
+-CONFIGURE_FILE( "${PROJECT_SOURCE_DIR}/cmake_uninstall.cmake.in"
+-                "${PROJECT_BINARY_DIR}/cmake_uninstall.cmake"
+-                IMMEDIATE @ONLY )
+-
+-ADD_CUSTOM_TARGET( uninstall
+-  "${CMAKE_COMMAND}" -P "${PROJECT_BINARY_DIR}/cmake_uninstall.cmake" )
+-
+ message("-------------------------------------------------------------------")
+ message(" Required for build:   qt4-dev (>>= 4.6) ")
+ message(" Required for runtime: nmap+nping ( >= 6.00 ), dig ")
index ffb545d0cd18de969dd70b6a9fc18a09d70d948b..6457fee79399554dc3ec3b8c0b987bee168ac0d8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -34,9 +34,11 @@ RDEPEND="${DEPEND}
 S=${WORKDIR}/${MY_P}
 
 DOCS=( AUTHORS HACKING NEWS TODO Translation )
+PATCHES=( "${FILESDIR}/${P}-kdelibs-4.14.11.patch" )
 
 src_prepare() {
        l10n_for_each_disabled_locale_do nmapsi_disable_locale
+       cmake-utils_src_prepare
 }
 
 src_configure() {