dev-python/setuptools: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:03:15 +0000 (22:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:09:38 +0000 (22:09 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/setuptools-42.0.2.ebuild
dev-python/setuptools/setuptools-44.0.0.ebuild

index e9fbfe3f93bfd7a864c2b4b0534f4a40ba8eeb57..886d7f12a2e2a692c64f144f8410b1b04ab622b5 100644 (file)
@@ -33,7 +33,9 @@ BDEPEND="
                dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
                dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
                dev-python/wheel[${PYTHON_USEDEP}]
-               virtual/python-futures[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       dev-python/futures[${PYTHON_USEDEP}]
+               ' -2)
        )
 "
 PDEPEND="
index 07d5af2b66e964fbf99eb61adaaff5f39c291f1d..0f44927d1033d86118a3bbd87e01722972016337 100644 (file)
@@ -33,7 +33,9 @@ BDEPEND="
                dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
                dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
                dev-python/wheel[${PYTHON_USEDEP}]
-               virtual/python-futures[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       dev-python/futures[${PYTHON_USEDEP}]
+               ' -2)
        )
 "
 PDEPEND="