app-emulation/qemu: fix inverted logic in configure stage, bug #611238
authorMatthias Maier <tamiko@gentoo.org>
Sat, 4 Mar 2017 16:06:19 +0000 (10:06 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Sat, 4 Mar 2017 16:09:39 +0000 (10:09 -0600)
Package-Manager: Portage-2.3.3, Repoman-2.3.2

app-emulation/qemu/qemu-2.8.0-r6.ebuild
app-emulation/qemu/qemu-9999.ebuild

index 9c2b891c89e42938a67722bfb25bc83ac0a15619..584a2e15773b8a5dfedcaed4e84e3bd4809da45f 100644 (file)
@@ -413,10 +413,10 @@ qemu_src_configure() {
        # Disable options not used by user targets as the default configure
        # options will autoprobe and try to link in a bunch of unused junk.
        conf_softmmu() {
-               if [[ ${buildtype} == "user" ]] ; then
-                       echo "--disable-${2:-$1}"
-               else
+               if [[ ${buildtype} == "softmmu" ]] ; then
                        use_enable "$@"
+               else
+                       echo "--disable-${2:-$1}"
                fi
        }
        conf_opts+=(
index 580f45bfabd9e1621b5c1b8a6fffaa10423116f3..46221a38b07cadf6bbe630fc98aa72afb47f8ad0 100644 (file)
@@ -392,10 +392,10 @@ qemu_src_configure() {
        # Disable options not used by user targets as the default configure
        # options will autoprobe and try to link in a bunch of unused junk.
        conf_softmmu() {
-               if [[ ${buildtype} == "user" ]] ; then
-                       echo "--disable-${2:-$1}"
-               else
+               if [[ ${buildtype} == "softmmu" ]] ; then
                        use_enable "$@"
+               else
+                       echo "--disable-${2:-$1}"
                fi
        }
        conf_opts+=(