dev-util/pkgcheck: add support for building/installing man page
authorTim Harder <radhermit@gentoo.org>
Mon, 24 Aug 2015 00:58:23 +0000 (20:58 -0400)
committerTim Harder <radhermit@gentoo.org>
Mon, 24 Aug 2015 00:58:23 +0000 (20:58 -0400)
dev-util/pkgcheck/pkgcheck-9999.ebuild

index c786406a64192402194f5e49de34cfb820340b33..316538edf1fb723390ba2db4845ddd7ae4a737d6 100644 (file)
@@ -24,12 +24,17 @@ RDEPEND="=sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
        =dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]"
+[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
 
 pkg_setup() {
        # disable snakeoil 2to3 caching...
        unset PY2TO3_CACHEDIR
 }
 
+python_compile_all() {
+       [[ ${PV} == *9999 ]] && emake -C doc man
+}
+
 python_test() {
        esetup.py test
 }
@@ -37,6 +42,12 @@ python_test() {
 python_install_all() {
        local DOCS=( AUTHORS NEWS.rst )
        distutils-r1_python_install_all
+
+       if [[ ${PV} == *9999 ]]; then
+               emake -C doc PREFIX=/usr DESTDIR="${D}" install_man
+       else
+               doman man/*
+       fi
 }
 
 pkg_postinst() {