dev-util/vint: verbump to 0.3.19
authorIlya Tumaykin <itumaykin@gmail.com>
Mon, 2 Jul 2018 12:06:05 +0000 (15:06 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 6 Jul 2018 21:47:53 +0000 (23:47 +0200)
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/9054

dev-util/vint/Manifest
dev-util/vint/vint-0.3.19.ebuild [new file with mode: 0644]

index a9bc75ea4358e6a9262389c7908b2cabd48d658d..25608badb872b1a2604912272e68d25f3d6564b4 100644 (file)
@@ -1 +1,2 @@
 DIST vint-0.3.18.tar.gz 95865 BLAKE2B 0f7e61b720aa0998091b9b40118b199392fbf1aeace8801d683e8249179cd3d792e15b42df6d34c567c4df1830629a80e6043e87092f37dc46a0e57c6a56cf53 SHA512 1d3e04527a8f5ffae29395010a88258c1771aff2798143eff6572400eaf96323cad04353a7fcee68d9407afde5808446f515fd3d7e8e62de4bef28edf214ebdd
+DIST vint-0.3.19.tar.gz 96755 BLAKE2B 0b03807a4286b3e030e00c112dd0e879fa39e0d2333d46ea159555de50b30098d9a8b2345da8e18b7e1e5c814f10678df2e64398a615bf381186faa0036939f5 SHA512 b9024ed1cd8a18a916798e691ba0db31985034b2420e33c094459a48254c7c8f6fe89a1a64858a67ff95b0b48e67a780cf975940646af2685d2b95640e8121f9
diff --git a/dev-util/vint/vint-0.3.19.ebuild b/dev-util/vint/vint-0.3.19.ebuild
new file mode 100644 (file)
index 0000000..1e5cc17
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lint tool for Vim script language"
+HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.org/project/vim-vint/"
+SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
+       >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+       virtual/python-enum34[${PYTHON_USEDEP}]
+       virtual/python-pathlib[${PYTHON_USEDEP}]
+       virtual/python-typing[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.3.2[${PYTHON_USEDEP}]
+               >=dev-python/pytest-cov-2.5.1[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+       )
+"
+
+python_test() {
+       py.test -v || die "Test suite failed with ${EPYTHON}"
+}