app-emulation/diskimage-builder: 2.37.3 use stage3 to build gentoo images
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 28 May 2020 17:04:38 +0000 (12:04 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 28 May 2020 17:04:51 +0000 (12:04 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
RepoMan-Options: --force
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-emulation/diskimage-builder/Manifest
app-emulation/diskimage-builder/diskimage-builder-2.36.0.ebuild [deleted file]
app-emulation/diskimage-builder/diskimage-builder-2.37.1.ebuild [deleted file]
app-emulation/diskimage-builder/diskimage-builder-2.37.3.ebuild [moved from app-emulation/diskimage-builder/diskimage-builder-2.35.0.ebuild with 96% similarity]
app-emulation/diskimage-builder/diskimage-builder-9999.ebuild

index 096268af0c362015b833fdc636b50a19acf297c5..170e92ebed2d6262ec9a7ded26a1dd48ac94eab6 100644 (file)
@@ -1,3 +1 @@
-DIST diskimage-builder-2.35.0.tar.gz 439947 BLAKE2B 9b148948caef031f44992aaa2b0463b6cc9390b0591fdfe6e82d8258becda61eb5aa0d87ae91ed73523057ae357dcf327d7ca9d8d6a1b66da7f2d535d6c32dc1 SHA512 c5ad15c7a793a6c4b17e09fb119ad1444273f930741ae68491ce3a95f416cf8bb76ed0f6df4e34e03359355426c9189f2f5a8b730cb9ffd027a0bbd676f62310
-DIST diskimage-builder-2.36.0.tar.gz 441509 BLAKE2B 4f8ec1686df8438c53eb088e52b954d0b84c8f327108599970f987db8de0f5ea7491e123c5f41fa9ff058d8f9d30238a533357b01e1cb671dd1fb3eb96ad28cb SHA512 f3fc13195742b25b8cca72d8b5630900d77f5af69dd9d153c44875e9e8f8f27393a8478a4adcdc05ea9d5b73b742e066edb5ab636bfd8d88c404c8f0fe33f1e7
-DIST diskimage-builder-2.37.1.tar.gz 442597 BLAKE2B ea70b0ef7573ae7ccce93bf6792e9866e8799f746ab87db5b2fea4b4c5bb41c18bc4fd1b8fdc7b0bc401be6ed940cf0964391ed235507fd80ebb6a39c811da1c SHA512 5901a13db4a94418bfe0b0e6dde855e32d3286ad31ba922839cba390d1adb79eb36ea7b14133d8e71e712ca562f7ebaa65637c2535276c3ef10b72a3047c3eed
+DIST diskimage-builder-2.37.3.tar.gz 444207 BLAKE2B 602a5063d54d3d4bce1a2b5a3e941ef5ad69709733c9aa9543c6b3f7e7ef1bd45399d0fd7e5b2f6dc3dc8f38fba1bf108473f89252c4b9b181f97c4dc02af18e SHA512 fff684c348f5b2ba0d3ae5ce955be4b1d47cead934c96eddcd137b1568961661c949cb53d3134359d0fa8ab753c559b7f83d5555cb6dc8fbd121cb9d05a4a66a
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.36.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.36.0.ebuild
deleted file mode 100644 (file)
index 092a05d..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Golden Disk Image builder."
-HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
-if [[ ${PV} == 9999* ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
-else
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
-       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
-       >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
-       app-emulation/qemu
-       sys-block/parted
-       sys-fs/multipath-tools
-       sys-fs/dosfstools
-       sys-apps/gptfdisk
-       !dev-python/dib-utils[${PYTHON_USEDEP}]"
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.37.1.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.37.1.ebuild
deleted file mode 100644 (file)
index 720474e..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="Golden Disk Image builder."
-HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
-if [[ ${PV} == 9999* ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
-else
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
-       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
-       >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
-       app-emulation/qemu
-       sys-block/parted
-       sys-fs/multipath-tools
-       sys-fs/dosfstools
-       sys-apps/gptfdisk
-       !dev-python/dib-utils[${PYTHON_USEDEP}]"
similarity index 96%
rename from app-emulation/diskimage-builder/diskimage-builder-2.35.0.ebuild
rename to app-emulation/diskimage-builder/diskimage-builder-2.37.3.ebuild
index be52861a223fd7ca8969ba0989c2e729513eb077..3f1829944bee020501a7b8df8c9e34e8fb6949a2 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 inherit distutils-r1
 
 DESCRIPTION="Golden Disk Image builder."
index 092a05de76521c2d6b4dc1fafa5cd798a2b27dec..720474e33c4844f324578cc78eb1b4ec252c1356 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 inherit distutils-r1
 
 DESCRIPTION="Golden Disk Image builder."