gnome-extra/gnome-documents: bump to 3.22.1
authorMart Raudsepp <leio@gentoo.org>
Tue, 21 Mar 2017 04:05:32 +0000 (06:05 +0200)
committerMart Raudsepp <leio@gentoo.org>
Tue, 21 Mar 2017 04:14:52 +0000 (06:14 +0200)
Package-Manager: Portage-2.3.4, Repoman-2.3.1

gnome-extra/gnome-documents/Manifest
gnome-extra/gnome-documents/gnome-documents-3.22.1.ebuild [new file with mode: 0644]

index 24ba01aa3803a1bd8e3b805d2a5105a3550abba8..6786952f0b6e2a0d2d155e31030ff5131c2d1059 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnome-documents-3.20.1.tar.xz 2327412 SHA256 c73810ded97431360ba80c127d3244b1e6e416643fba0ba96411d22729211394 SHA512 f879a9761f5a34cb006a7df3933dfbd8f4c54e3fecf1601bd48d05a0994821eb8e7f5ba54f7ac5a2b6cd9674b733dd74445592d1e20f6903073965ec79072916 WHIRLPOOL d66fd64403d27610725562edb444ee93108984a7b5dec7dd7322f896734e75241f67e3939cd0000f4031f531c9b9fc3354d13436394725fa845a25096596498c
 DIST gnome-documents-3.22.0.tar.xz 2336988 SHA256 edf5cd6b7b7f5847217b60885358030598e551010087d2a9d1765ae6777041ad SHA512 82bf3b67e6ebe3a8a2415d9bacfa4323eab31a32d23b852f07f30579d5437c1f436c2a0d25174e9ba9131a90eb1900dfe33cfcc214fe600a903edf00de14b325 WHIRLPOOL 254f8c30617f1aea952e07d69ce0ca43f91b208ef2d8623f79624c7371901112bf8bd409ee9ded5f779953a91117931eb2b1362888e928f7654353a939fd3fee
+DIST gnome-documents-3.22.1.tar.xz 2313364 SHA256 3879f1f31c3339cd69355945b4cf217e25dc6ed9cc7577d25d0353e0a1b8e8cb SHA512 519efc6f68d3a1ce4905d5aa1d16d273ad14323979a0c2188731af6ba3a5830b809186021f8138ce14a3feb398a005bed737d0c89c1032e4bd985123207bd481 WHIRLPOOL 968801d8a2c86b91199f85b21bb6f6652885c3ad4d70520e6234838f87591ca8f7190c77ca98d2f9099ee10654518f303c2c542ab94193425592beb79f576b68
diff --git a/gnome-extra/gnome-documents/gnome-documents-3.22.1.ebuild b/gnome-extra/gnome-documents/gnome-documents-3.22.1.ebuild
new file mode 100644 (file)
index 0000000..25b1a4b
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A document manager application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Documents"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# Need gdk-pixbuf-2.25 for gdk_pixbuf_get_pixels_with_length
+COMMON_DEPEND="
+       >=app-misc/tracker-1:=[miner-fs]
+       >=app-text/evince-3.13.3[introspection]
+       >=app-text/libgepub-0.4[introspection]
+       dev-libs/gjs
+       >=dev-libs/glib-2.39.3:2
+       >=dev-libs/gobject-introspection-1.31.6:=
+       >=dev-libs/libgdata-0.13.3:=[crypt,gnome-online-accounts,introspection]
+       gnome-base/gnome-desktop:3=[introspection]
+       >=media-libs/clutter-1.10:1.0
+       >=media-libs/clutter-gtk-1.3.2:1.0[introspection]
+       >=net-libs/gnome-online-accounts-3.2.0[introspection]
+       >=net-libs/libsoup-2.41.3:2.4
+       >=net-libs/libzapojit-0.0.2[introspection]
+       >=net-libs/webkit-gtk-2.6:4[introspection]
+       >=x11-libs/gdk-pixbuf-2.25:2[introspection]
+       >=x11-libs/gtk+-3.19.1:3[introspection]
+       x11-libs/pango[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+       media-libs/clutter[introspection]
+       net-misc/gnome-online-miners
+       sys-apps/dbus
+       x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+       dev-libs/libxslt
+       >=dev-util/intltool-0.50.1
+       dev-util/itstool
+       virtual/pkgconfig
+"
+# eautoreconf requires yelp-tools