Fix line handling if package is not installed and contains special character. Add...
authorMike Pagano <mpagano@gentoo.org>
Fri, 21 Oct 2011 13:30:08 +0000 (13:30 +0000)
committerMike Pagano <mpagano@gentoo.org>
Fri, 21 Oct 2011 13:30:08 +0000 (13:30 +0000)
Package-Manager: portage-2.2.0_alpha70/cvs/Linux x86_64

app-portage/portpeek/ChangeLog
app-portage/portpeek/portpeek-1.9.74.ebuild [new file with mode: 0644]
app-portage/portpeek/portpeek-2.0.13.ebuild [new file with mode: 0644]

index a86d6a130011d20c9f77b24922ee292cddc439b6..68b8eec4a7bd00ed26b205e56f580e9152be5683 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-portage/portpeek
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/ChangeLog,v 1.122 2011/10/21 13:27:24 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/ChangeLog,v 1.123 2011/10/21 13:30:08 mpagano Exp $
+
+*portpeek-2.0.13 (21 Oct 2011)
+
+  21 Oct 2011; Michael Pagano <mpagano@gentoo.org> +portpeek-2.0.13.ebuild:
+  Fix line handling if package is not installed and contains special character.
+  Add parameter to ask the user for confirmation before modifiying package
+  files. Update man page for fix-confirm functionality.
 
 *portpeek-1.9.74 (21 Oct 2011)
 
diff --git a/app-portage/portpeek/portpeek-1.9.74.ebuild b/app-portage/portpeek/portpeek-1.9.74.ebuild
new file mode 100644 (file)
index 0000000..503d050
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/portpeek-1.9.74.ebuild,v 1.1 2011/10/21 13:27:24 mpagano Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-portage/gentoolkit-0.3.0.4
+       >=sys-apps/portage-2.1.10.11
+       || ( dev-lang/python:2.6 dev-lang/python:2.7 )"
+
+pkg_setup() {
+       python_set_active_version 2
+}
+
+src_prepare() {
+       python_convert_shebangs 2 portpeek
+}
+
+src_install() {
+       dobin ${PN} || die "dobin failed"
+       doman *.[0-9]
+}
diff --git a/app-portage/portpeek/portpeek-2.0.13.ebuild b/app-portage/portpeek/portpeek-2.0.13.ebuild
new file mode 100644 (file)
index 0000000..cb5a2f1
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/portpeek-2.0.13.ebuild,v 1.1 2011/10/21 13:30:08 mpagano Exp $
+
+EAPI="2"
+PYTHON_DEPEND="3"
+
+inherit eutils python
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-portage/gentoolkit-0.3.0.4
+       >=sys-apps/portage-2.1.10.11"
+
+pkg_setup() {
+       python_set_active_version 3
+}
+
+src_prepare() {
+       python_convert_shebangs 3 portpeek
+}
+
+src_install() {
+       dobin ${PN} || die "dobin failed"
+       doman *.[0-9]
+}