dev-util/colm: various fixes
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>
Sun, 20 Oct 2019 22:20:08 +0000 (00:20 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 20 Oct 2019 22:36:57 +0000 (00:36 +0200)
* EAPI 7
* license fix
* do not install static library

Closes: https://bugs.gentoo.org/698066
Closes: https://github.com/gentoo/gentoo/pull/13293
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/colm/colm-0.13.0.6-r1.ebuild [new file with mode: 0644]

diff --git a/dev-util/colm/colm-0.13.0.6-r1.ebuild b/dev-util/colm/colm-0.13.0.6-r1.ebuild
new file mode 100644 (file)
index 0000000..24c7916
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="COmputer Language Manipulation"
+HOMEPAGE="https://www.colm.net/open-source/colm/"
+SRC_URI="https://www.colm.net/files/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="app-text/asciidoc"
+
+src_configure() {
+       econf --disable-static
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}