sci-astronomy/kapteyn: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:30:19 +0000 (19:30 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:30:34 +0000 (19:30 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sci-astronomy/kapteyn/Manifest [deleted file]
sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch [deleted file]
sci-astronomy/kapteyn/kapteyn-2.3.ebuild [deleted file]
sci-astronomy/kapteyn/metadata.xml [deleted file]

diff --git a/sci-astronomy/kapteyn/Manifest b/sci-astronomy/kapteyn/Manifest
deleted file mode 100644 (file)
index 4bd408b..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST kapteyn-2.3.tar.gz 14496700 BLAKE2B afadff0024c8edcea8a0a24362266285e86861623aac614edaf98c5bfde1eb49baaab9311256ff5eb1ec0d223cbe406da55679a319b68d7a5bf760f422cab51e SHA512 7095d9f1faed1937817af48416027391e19bf416187b8cc7f0cc5fb1227efe715c0c6ff945e0e021d1a5e82353e9c3ad2c3a1236d3453b4904d6ca2f2a47747b
diff --git a/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch b/sci-astronomy/kapteyn/files/kapteyn-2.2-debundle_wcs.patch
deleted file mode 100644 (file)
index 035979b..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-Use system wcslib
-
-Patch written by Kacper Kowalik <xarthisius@gentoo.org>
-
---- a/setup.py
-+++ b/setup.py
-@@ -3,7 +3,8 @@
- from kapteyn import __version__ as version
- from glob import glob
- import sys, os
--
-+from subprocess import Popen, PIPE
-+from re import match
- try:
-    import numpy
- except:
-@@ -14,21 +15,27 @@
- '''
-    sys.exit(1)
--try:
--   wcslib_dir = glob('src/wcslib*/C/')[0]
--except:
--   print '''
---- Error.
--Unable to find WCSLIB source distribution.
--'''
--   sys.exit(1)
-+def pkgconfig(*packages, **kw):
-+    flag_map = {'-I': 'include_dirs', '-L': 'library_dirs', '-l': 'libraries'}
-+    arg = "--libs --cflags --modversion %s" % ' '.join(packages) 
-+    for tok in Popen(["pkg-config "+ arg],stdout=PIPE, shell=True).communicate()[0].split():
-+       token = tok.decode("utf-8")
-+       if(match("[0-9]",token)):
-+          kw.setdefault("version",[]).append(token)
-+       else:
-+          kw.setdefault(flag_map.get(token[:2]), []).append(token[2:])
-+    return kw
- include_dirs = []
- numdir = os.path.dirname(numpy.__file__)
- ipath = os.path.join(numdir, numpy.get_include())
- include_dirs.append(ipath)
- include_dirs.append('src')
--include_dirs.append(wcslib_dir)
-+
-+WCSLIB = pkgconfig('wcslib')
-+WCSVERSION = Popen(["pkg-config --modversion"],stdout=PIPE, shell=True).communicate()[0].split()
-+
-+include_dirs += WCSLIB['include_dirs']
- short_descr = "Kapteyn Package: Python modules for astronomical applications"
-@@ -94,27 +101,6 @@
-    "xyz.c"
- ]
--wcslib_src = [
--   "cel.c",
--   "lin.c",
--   "log.c",
--   "prj.c",
--   "spc.c",
--   "sph.c",
--   "spx.c",
--   "tab.c",
--   "wcs.c",
--   "wcsfix.c",
--   "wcshdr.c",
--   "wcsprintf.c",
--   "wcstrig.c",
--   "wcsunits.c",
--   "wcsutil.c",
--   "wcserr.c",
--   "flexed/wcsulex.c",
--   "flexed/wcsutrn.c"
--]
--
- ndimg_src = [
-    "nd_image.c",
-    "ni_filters.c",
-@@ -125,8 +111,7 @@
-    "ni_support.c",
- ]
--wcs_src       = (   ['src/'        + source for source in wcsmod_src]
--                  + [wcslib_dir    + source for source in wcslib_src]  )
-+wcs_src       = ( ['src/'        + source for source in wcsmod_src] )
- _nd_image_src = ['src/ndimg/'  + source for source in ndimg_src]
-@@ -168,7 +153,8 @@
-       Extension(
-          "wcs", wcs_src,
-           include_dirs=include_dirs,
--          define_macros=define_macros
-+          define_macros=define_macros,
-+          libraries=WCSLIB['libraries']
-       ),
-       Extension(
-          "ascarray",
diff --git a/sci-astronomy/kapteyn/kapteyn-2.3.ebuild b/sci-astronomy/kapteyn/kapteyn-2.3.ebuild
deleted file mode 100644 (file)
index 91ca272..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of python tools for astronomy"
-HOMEPAGE="https://www.astro.rug.nl/software/kapteyn/"
-SRC_URI="https://www.astro.rug.nl/software/kapteyn/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="
-       sci-astronomy/wcslib
-       dev-python/numpy[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]"
-
-DOCS=( CHANGES.txt README.txt doc/${PN}.pdf )
-
-PATCHES=( "${FILESDIR}"/${PN}-2.2-debundle_wcs.patch )
-
-python_prepare_all() {
-       rm -r src/wcslib-4.* || die
-       distutils-r1_python_prepare_all
-}
diff --git a/sci-astronomy/kapteyn/metadata.xml b/sci-astronomy/kapteyn/metadata.xml
deleted file mode 100644 (file)
index 57bfac1..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-astronomy@gentoo.org</email>
-    <name>Gentoo Astronomy Project</name>
-  </maintainer>
-  <longdescription lang="en">
-  The Kapteyn Package is a collection of Python modules and applications
-  made by the computer group of the Kapteyn Astronomical Institute,
-  University of Groningen, The Netherlands. The purpose of the package
-  is to provide tools for the development of astronomical applications
-  with Python.
-</longdescription>
-</pkgmetadata>