dev-python/os-brick: 2.3.3 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 15 Aug 2018 16:26:57 +0000 (11:26 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 15 Aug 2018 16:27:16 +0000 (11:27 -0500)
Package-Manager: Portage-2.3.44, Repoman-2.3.10

dev-python/os-brick/Manifest
dev-python/os-brick/os-brick-2.3.3.ebuild [new file with mode: 0644]

index 29dca82da59eedba7c3870111661e1b165609abc..171f8a49b595a0d1def15f174c6d62dbadd62a27 100644 (file)
@@ -1,2 +1,3 @@
 DIST os-brick-1.15.5.tar.gz 161371 BLAKE2B 0fdfb5978cb1d1ca635d64f98b75210b03353c033affd9834294c4d505a0d9e580f0f829a5e5c96fdb53f1cf2a29ba63ded6fbba4ae662a5dad0d20fdf98356b SHA512 c73c0f227e68aeba80b6b5687fc876e7dfe3ba36a800b7241ed08a0f189e0a57adfdf3b3e1f63230514ddac848be84e1f05e6be6aa0f50412695c6d37124717d
 DIST os-brick-2.3.1.tar.gz 166518 BLAKE2B d58acd3ffffa6a5ca328eda9f74f4e9897846b047fc96777fb438c5e5a2fbef642e1672bd7f216acddef29138543627ef79fb6e6fc01e9e7cb34ee59663bedd8 SHA512 243d574289a95a07c43b112f9c00372a8b95560628f1d86f3ea750755b4026ef9426864a216a459c159b7275218a08df585aaf0f4f3c973d63af5a59083a6b2b
+DIST os-brick-2.3.3.tar.gz 166088 BLAKE2B d5bdb748f8cb00ceef7649198470be3beb58bc9824ce74d8781c65ad87125b5480dc22fa978817fb89842ed347fbe7f0d1a3b5c94642ca418b7c6a694423d56d SHA512 8373641ee102eb7e522da400dcd960672341828ce252610bc65b042e5d0e614ec8af29d8fc87564a29b62615d71aa8b1074b4155c8f70cf35232fb2b37105f94
diff --git a/dev-python/os-brick/os-brick-2.3.3.ebuild b/dev-python/os-brick/os-brick-2.3.3.ebuild
new file mode 100644 (file)
index 0000000..f562cbd
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/cinder"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+       !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+       >=dev-python/oslo-concurrency-3.25.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-log-3.26.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+       !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+       !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/os-win-3.0.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}