sci-physics/root: version bump to 6.20.02
authorGuilherme Amadio <amadio@gentoo.org>
Mon, 16 Mar 2020 12:25:16 +0000 (13:25 +0100)
committerGuilherme Amadio <amadio@gentoo.org>
Mon, 16 Mar 2020 13:32:39 +0000 (14:32 +0100)
The dependency on media-libs/cudnn when USE=cuda has been made
optional upstream.

Closes: https://bugs.gentoo.org/711470
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
sci-physics/root/Manifest
sci-physics/root/root-6.20.02.ebuild [moved from sci-physics/root/root-6.20.00-r1.ebuild with 95% similarity]

index 2647cb1cf94aa656d2a2b8ed7d7c5ea03f4c8c55..6735930f074efd4ddf55596a47d710c61ef1830a 100644 (file)
@@ -2,4 +2,4 @@ DIST root_v6.12.06.source.tar.gz 162284452 BLAKE2B 944b5e899677bab40842d7ec969ff
 DIST root_v6.14.08.source.tar.gz 162474562 BLAKE2B f8bfdabb4d91bbdfbab0b17626fff1f8aa265292996d857025cbd1543306f3ec540a1afb080788bfc7149ea835932b59d7c54dcd802354e31294ba2e5e9d2366 SHA512 827e39efbf3c69429a0a256127ca9f87550d9084c34c715bddccbf87a8c111c367b9a0ac6882aac747c9b48f4a3effb3747b4df567429910c93ee64dfe35df5b
 DIST root_v6.16.00.source.tar.gz 164836293 BLAKE2B 9d8f02631bdc1fa1775cbdaf50dd1feacd9b3c86b81d679ba6f0ca3c5787cd1d22ef7c33358b608361a01ad4f0aff3e8c749649d24773a35c52ce87f808d08f5 SHA512 17e5b9815973773e30ff83c2f4028e9e93691c1ecb824c162c8b3e02d1f6666fb8e0b72a5d0652a90032af146d92d271cbffcd634fb6fe6a63bdf46d672789bf
 DIST root_v6.18.04.source.tar.gz 165938450 BLAKE2B d6545dfa95817940f2bb6b5b49252eca1958df518a4bc05c4857df60a015a39d0df09ea077465533e6ebc815d04e1742da19d18b7af02b5446f9e73dc92e3c16 SHA512 cfcbdd2db4edf55845a7cd1e6ec0cdf714a7ceacb039fa6fb627d7300d6f849b3b462bab724e33b1d6b08eb22ba42c43b7d64c0c6c47dc8a3bb652f86979f2c6
-DIST root_v6.20.00.source.tar.gz 168051568 BLAKE2B 6d0b037cc769a186885c61d3ed9eb3bbb4b0dbc357d2ede8383d4491781ef642d19c5ff3c354aec49abc36cb7da0aac9ba346cd0896ed9b54b03080486031804 SHA512 a6e068430bfdc01922a7f6a4b14fd0b183185d8ef41862c6846b410c814914292573170ab58166e827b706726e27f95ce8ff389f43bc8a76a715992b7d6d32f9
+DIST root_v6.20.02.source.tar.gz 168054715 BLAKE2B b57a40ffb5a69aa7060d5237b701c367198b3e9743c82fa9edfc1b51169c77b68b4ad9c826bbbd2f125bc8ebc7498b4173efb1216a5752a29fc113c7a30f23ab SHA512 04d5ef3afc70fc6ed4a2bdf01a1bc777222c27cf2f9dc39512de81a19cc1e6ec87d8d21cf6ba7d7270498c1c1cd571f3bbfd2699fc49713f1cc685b087b36316
similarity index 95%
rename from sci-physics/root/root-6.20.00-r1.ebuild
rename to sci-physics/root/root-6.20.02.ebuild
index 3b2cfb7aa277650e4e27df4a1b13e2eaccb1f36b..07d451fd715914c09a5000eac7c7886fcbffd8ae 100644 (file)
@@ -15,7 +15,7 @@ DESCRIPTION="C++ data analysis framework and interpreter from CERN"
 HOMEPAGE="https://root.cern"
 SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
 
-IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
+IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda cudnn +davix debug emacs
        +examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
        mpi mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
        qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc
@@ -29,6 +29,7 @@ KEYWORDS="~amd64 ~x86"
 REQUIRED_USE="
        ^^ ( c++11 c++14 c++17 )
        cuda? ( tmva !c++17 )
+       cudnn? ( cuda )
        !X? ( !asimage !opengl !qt5 )
        davix? ( ssl xml )
        python? ( ${PYTHON_REQUIRED_USE} )
@@ -69,6 +70,7 @@ CDEPEND="
        )
        asimage? ( media-libs/libafterimage[gif,jpeg,png,tiff] )
        cuda? ( >=dev-util/nvidia-cuda-toolkit-9.0 )
+       cudnn? ( dev-libs/cudnn )
        davix? ( net-libs/davix )
        emacs? ( >=app-editors/emacs-23.1:* )
        fftw? ( sci-libs/fftw:3.0= )
@@ -140,6 +142,9 @@ src_prepare() {
 
 src_configure() {
        local mycmakeargs=(
+               -DCMAKE_C_COMPILER=$(tc-getCC)
+               -DCMAKE_CXX_COMPILER=$(tc-getCXX)
+               -DCMAKE_CUDA_HOST_COMPILER=$(tc-getCXX)
                -DCMAKE_C_FLAGS="${CFLAGS}"
                -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
                -DCMAKE_CXX_STANDARD=$((usev c++11 || usev c++14 || usev c++17) | cut -c4-)
@@ -189,6 +194,7 @@ src_configure() {
                -Dclad=OFF
                -Dcocoa=$(usex aqua)
                -Dcuda=$(usex cuda)
+               -Dcudnn=$(usex cudnn)
                -Dcxxmodules=OFF # requires clang, unstable
                -Ddavix=$(usex davix)
                -Ddataframe=ON
@@ -221,7 +227,8 @@ src_configure() {
                -Dpgsql=$(usex postgres)
                -Dpythia6=$(usex pythia6)
                -Dpythia8=$(usex pythia8)
-               -Dpython=$(usex python)
+               -Dpyroot=$(usex python) # python was renamed to pyroot
+               -Dpyroot_experimental=OFF # use standard PyROOT for now
                -Dqt5web=$(usex qt5)
                -Droofit=$(usex roofit)
                -Droot7=$(usex root7)