dev-libs/librelp: Bump to v1.2.13
authorThomas Deutschmann <whissi@gentoo.org>
Sun, 26 Feb 2017 13:59:11 +0000 (14:59 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 26 Feb 2017 14:10:58 +0000 (15:10 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-libs/librelp/Manifest
dev-libs/librelp/librelp-1.2.13.ebuild [new file with mode: 0644]

index e8395147e0e9dc181c177c3b1818c9614570d95c..3c2256a3bf519ca45c738c13efd2a95743de24ca 100644 (file)
@@ -1 +1,2 @@
 DIST librelp-1.2.12.tar.gz 437945 SHA256 0355730524f7b20bed1b85697296b6ce57ac593ddc8dddcdca263da71dee7bd7 SHA512 bfc38882404e06c047bdabd203d71beba67bc5a717d2d6733863f15f0a3a09b4a792a628a1653c102c828fde7ff67cc8ade637de785399ab48a68605b23a72ed WHIRLPOOL 0d3193b3f0f21e940793df0f2c53bb46944c1fbfe4f7aee8b0ecbaead3053185f981a695eaae65d6ea1581ea4a8011e83e2ffff0436ab15bdd4f82b9a012f9a3
+DIST librelp-1.2.13.tar.gz 437877 SHA256 38df3ca7feba55850602bbefe3ac3c035e7666691d46b8bfbff1f1a4c774c0c7 SHA512 62d22998711ed82f30a1fce7c6b25dca514717c513d5833ce9ea6951d20f6922787213285be710c30fd28fd80d07ee9313f92cc7e09531ca8ac5e12627dbc868 WHIRLPOOL e420c237d1307b1e507385e005bcfde51183efe80bdcedaedfc6da22fcb55407dd47b696e602daa2f706418a9d49087dfa3628daf19147fbd5402ef7b37d8d72
diff --git a/dev-libs/librelp/librelp-1.2.13.ebuild b/dev-libs/librelp/librelp-1.2.13.ebuild
new file mode 100644 (file)
index 0000000..9873f1f
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="An easy to use library for the RELP protocol"
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ doc? ( FDL-1.3 )"
+
+# subslot = soname version
+SLOT="0/0.2.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="debug doc +ssl static-libs"
+
+RDEPEND="
+       ssl? ( >=net-libs/gnutls-3.3.17.1:0= )
+"
+
+DEPEND="
+       ssl? ( >=net-libs/gnutls-3.3.17.1:0= )
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       sed -i \
+               -e 's/ -g"/"/g' \
+               configure.ac || die "sed failed"
+
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable debug)
+               $(use_enable ssl tls)
+               $(use_enable static-libs static)
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       local DOCS=( ChangeLog )
+       use doc && local HTML_DOCS=( doc/relp.html )
+       default
+
+       find "${ED}"usr/lib* -name '*.la' -delete || die
+}