sys-apps/util-linux: Introduced "logger" and "su" USE flags
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 19 Nov 2019 08:42:52 +0000 (09:42 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 19 Nov 2019 10:37:03 +0000 (11:37 +0100)
Thanks-to: fling <fling@member.fsf.org>
Bug: https://bugs.gentoo.org/699930
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/util-linux/metadata.xml
sys-apps/util-linux/util-linux-9999.ebuild

index ed7b2cf02a025c4772a438c46960749c34734c75..dd6f8b1b1ccfff42936df3ed712908d0c6459d8d 100644 (file)
@@ -11,7 +11,9 @@
        <flag name="fdformat">build fdformat (floppy disk format)</flag>
        <flag name="hardlink">build hardlink program</flag>
        <flag name="kill">build the kill program</flag>
+       <flag name="logger">build the logger program</flag>
        <flag name="pam">build runuser helper</flag>
+       <flag name="su">build the su program</flag>
        <flag name="suid">
                install mount/umount as setuid so non-root users may mount/umount devices,
                and wall/write as setgid so non-root users can notify other users
index fcdde6fa579645fb788dce343a4fb14311852976..ba69e1349e111a2e8a7c03df42930b61be19a1ec 100644 (file)
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
 
 LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
 SLOT="0"
-IUSE="build caps +cramfs fdformat hardlink kill ncurses nls pam python +readline selinux slang static-libs +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="build caps +cramfs fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
 
 # Most lib deps here are related to programs rather than our libs,
 # so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -49,10 +49,15 @@ BDEPEND="
 "
 RDEPEND="${DEPEND}
        hardlink? ( !app-arch/hardlink )
+       logger? ( !>=app-admin/sysklogd-2.0[logger] )
        kill? (
                !sys-apps/coreutils[kill]
                !sys-process/procps[kill]
        )
+       su? (
+               !<sys-apps/shadow-4.7-r2
+               !>=sys-apps/shadow-4.7-r2[su]
+       )
        !net-wireless/rfkill
        !sys-process/schedutils
        !sys-apps/setarch
@@ -168,7 +173,6 @@ multilib_src_configure() {
                        --disable-login
                        --disable-nologin
                        --disable-pylibmount
-                       --disable-su
                        --enable-agetty
                        --enable-bash-completion
                        --enable-line
@@ -182,10 +186,12 @@ multilib_src_configure() {
                        $(use_enable cramfs)
                        $(use_enable fdformat)
                        $(use_enable hardlink)
+                       $(use_enable kill)
+                       $(use_enable logger)
+                       $(use_enable su)
                        $(use_enable tty-helpers mesg)
                        $(use_enable tty-helpers wall)
                        $(use_enable tty-helpers write)
-                       $(use_enable kill)
                )
        else
                myeconfargs+=(