dev-python/jupyter_console: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:15:47 +0000 (21:15 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:22:34 +0000 (21:22 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jupyter_console/Manifest
dev-python/jupyter_console/jupyter_console-5.1.0.ebuild [deleted file]

index ee482030f0d8a9205b18a6f75e794b18df99851e..4b8519652e5d26bbb15d275b7ceb094e2d949481 100644 (file)
@@ -1,2 +1 @@
-DIST jupyter_console-5.1.0.tar.gz 26661 BLAKE2B 075035d02fee640ccf9a2a7bd22e5872727380bd54b1fed48bd53f6bee12da8ff3dc5f4ff258d0c03f7260e2b495d8cb313a4b4f49e4eb644f0b15988fe41577 SHA512 208a31886eb58c64541048e1f7ed75fccc888d34177f86dfaf10fb7dcd603130a8b3ecbe23cf4d80a75287b847128425f853715c494d2a7e4b4eed8a31058b5c
 DIST jupyter_console-6.0.0.tar.gz 27780 BLAKE2B da2b58461caa987bea0b323cedbc79ff24f31cb928602b8ae6dce1ed615008a8227d7a1bab47364e6d182cfd3bd6f548e355430efc505e7183a391ef26c08375 SHA512 27b333f439733c33062d3baa8b49ff673b10e22cb8c28c688ba604799838e899f93372bd2eaf4a94c97260d6dec043d6aef4421388d77e625b1ec43a3dedfa3f
diff --git a/dev-python/jupyter_console/jupyter_console-5.1.0.ebuild b/dev-python/jupyter_console/jupyter_console-5.1.0.ebuild
deleted file mode 100644 (file)
index 23b925e..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/ipython[${PYTHON_USEDEP}]
-       dev-python/ipykernel[${PYTHON_USEDEP}]
-       dev-python/jupyter_client[${PYTHON_USEDEP}]
-       >=dev-python/prompt_toolkit-1.0.0[${PYTHON_USEDEP}]
-       dev-python/pygments[${PYTHON_USEDEP}]
-       "
-DEPEND="${RDEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/pexpect[${PYTHON_USEDEP}]
-               >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
-       )
-       "
-
-python_prepare_all() {
-       # Prevent un-needed download during build
-       if use doc; then
-               sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
-       fi
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               emake -C docs html
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       nosetests --with-coverage --cover-package=jupyter_console jupyter_console || die
-}