Version bump
authorTristan Heaven <tristan@gentoo.org>
Fri, 12 Jan 2007 09:52:33 +0000 (09:52 +0000)
committerTristan Heaven <tristan@gentoo.org>
Fri, 12 Jan 2007 09:52:33 +0000 (09:52 +0000)
Package-Manager: portage-2.1.2_rc4-r8

games-board/qgo/ChangeLog
games-board/qgo/files/digest-qgo-1.5.3 [new file with mode: 0644]
games-board/qgo/qgo-1.5.3.ebuild [new file with mode: 0644]

index b09836cf401b9a91f327e6688bae7e01137a2560..1f579da4e93ec37f7faaf547f1083a0a6b4f5808 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for games-board/qgo
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/ChangeLog,v 1.24 2007/01/08 13:54:41 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/ChangeLog,v 1.25 2007/01/12 09:52:33 nyhm Exp $
+
+*qgo-1.5.3 (12 Jan 2007)
+
+  12 Jan 2007; Tristan Heaven <nyhm@gentoo.org>
+  -files/qgo-1.5.2-gatter.patch, -qgo-1.5.2.ebuild, -qgo-1.5.2-r1.ebuild,
+  +qgo-1.5.3.ebuild:
+  Version bump
 
 *qgo-1.5.2-r1 (08 Jan 2007)
 
diff --git a/games-board/qgo/files/digest-qgo-1.5.3 b/games-board/qgo/files/digest-qgo-1.5.3
new file mode 100644 (file)
index 0000000..dd8c96b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 61c69181e64040f68d539c475e1be6bd qgo-1.5.3.tar.gz 2303630
+RMD160 cce3dad470f69c75b53d148145ea0014abd7930a qgo-1.5.3.tar.gz 2303630
+SHA256 333141db45b83869d89e24bf7c336331304961c8f92ed7a1d4af89473faa465f qgo-1.5.3.tar.gz 2303630
diff --git a/games-board/qgo/qgo-1.5.3.ebuild b/games-board/qgo/qgo-1.5.3.ebuild
new file mode 100644 (file)
index 0000000..59cec46
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/qgo/qgo-1.5.3.ebuild,v 1.1 2007/01/12 09:52:33 nyhm Exp $
+
+inherit eutils qt3 games
+
+DESCRIPTION="A Qt Go client and SGF editor"
+HOMEPAGE="http://qgo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qgo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 3.3)"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       sed -i 's:$(datadir):/usr/share:' \
+               templates/Makefile.in \
+               || die "sed Makefile.in failed"
+       sed -i "s:/usr/share:${GAMES_DATADIR}:" \
+               templates/*.desktop \
+               || die "sed .desktop failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dodoc AUTHORS ChangeLog NEWS README TODO
+       prepgamesdirs
+}