net-misc/istioctl: Version bump to 1.1.17
authorManuel Rüger <mrueg@gentoo.org>
Wed, 16 Oct 2019 10:22:10 +0000 (12:22 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Wed, 16 Oct 2019 10:22:57 +0000 (12:22 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
net-misc/istioctl/Manifest
net-misc/istioctl/istioctl-1.1.17.ebuild [new file with mode: 0644]

index b48f2375900df02653f53d51c083cc54683b6994..133f0e8654c5ca239744cbad37088d103cb692ed 100644 (file)
@@ -1,2 +1,3 @@
 DIST istioctl-1.1.12.tar.gz 20720842 BLAKE2B c7b70ee162daabcf82cc8cbd8ec61d49b68189fcab43a1f04daa9dee6701075330557d2567cabae7f8fa37a2b3ebac23def53cca43930a9c1bf5079c15198f48 SHA512 a7aa37a2ec12b802d38a27cc4b6131ec604e14f0c64d2a3619f2918cc24cbf7bf0e291d58185e0481d544b28264f8782636abdca5afdacde6c3ad41ae616b90d
+DIST istioctl-1.1.17.tar.gz 20765634 BLAKE2B e5192176312cbbd8b8f0ae46026909539df6c4784376a9e997b98d8147e7e9d4435ba97cbcb00880c99dc0ab2cd3ebbd4f385354c086f8a5fe71db57a8243802 SHA512 8d2057fbcb636f1fabc24a2f4c29b5426a9b68b0870a46ac9b5db6ea1f39336e5c1c7b13f040b346edbc35d1f359aacda1efd35b5417bd2ed90e693009cdda15
 DIST istioctl-1.1.8.tar.gz 20718514 BLAKE2B 20b492932906bab3d8fd2e66452acf42a3b8fc07bb42e95217410b32ede68f2dc4256f4e33b104428996a3cfa2f30c798ccf2cc3794079c8936d353330763c88 SHA512 907bff4a7239e0e615fcc3ea92c98d944916dc88c744d574b5362e622729e8fb5a79e549a7f0beece5235918d7891ef6283e6b1e3f789980450d7eee1e131e2b
diff --git a/net-misc/istioctl/istioctl-1.1.17.ebuild b/net-misc/istioctl/istioctl-1.1.17.ebuild
new file mode 100644 (file)
index 0000000..ce116f5
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+GIT_COMMIT="149c2fc"
+
+KEYWORDS="~amd64"
+DESCRIPTION="Istio configuration command line utility"
+EGO_PN="istio.io/istio"
+HOMEPAGE="https://github.com/istio/istio"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/istio/istio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+       pushd "src/${EGO_PN}" || die
+       BUILDINFO="istio.io/istio/pkg/version.buildVersion=${PV}
+               istio.io/istio/pkg/version.buildGitRevision=${GIT_COMMIT}
+               istio.io/istio/pkg/version.buildStatus=Clean" \
+       VERBOSE=1 GOPATH="${WORKDIR}/${P}" TAG=${PV} emake istioctl
+       popd || die
+}
+
+src_install() {
+       dobin out/linux_amd64/release/${PN}
+       pushd "src/${EGO_PN}" || die
+       dodoc README.md
+}