dev-libs/libspt: Always use libtirpc now
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 22 Apr 2018 16:57:46 +0000 (18:57 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 22 Apr 2018 16:58:01 +0000 (18:58 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

dev-libs/libspt/libspt-1.1-r4.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libspt/libspt-1.1-r4.ebuild b/dev-libs/libspt/libspt-1.1-r4.ebuild
new file mode 100644 (file)
index 0000000..3c16485
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Library for handling root privilege"
+#HOMEPAGE="http://www.j10n.org/libspt/index.html"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="suid"
+RESTRICT="test"
+
+RDEPEND="net-libs/libtirpc"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-gentoo.patch"
+       "${FILESDIR}/${PN}-rpc.patch"
+)
+
+src_prepare() {
+       rm aclocal.m4
+
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf --with-libtirpc
+}
+
+src_install() {
+       default
+
+       if use suid; then
+               fperms 4755 /usr/libexec/sptagent
+       fi
+}