x11-apps/mesa-progs: Remove EGL_MESA_screen_surface demos.
authorMatt Turner <mattst88@gentoo.org>
Fri, 28 Aug 2015 23:52:15 +0000 (16:52 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 28 Aug 2015 23:57:44 +0000 (16:57 -0700)
Not useful, and not sure when Mesa actually supported this extension,
but it certainly doesn't any more.

Bug: https://bugs.gentoo.org/show_bug.cgi?id=555186

x11-apps/mesa-progs/mesa-progs-8.2.0.ebuild
x11-apps/mesa-progs/mesa-progs-9999.ebuild

index 81090edea198f1372e3666696a819b8b239374c9..d3c9bbf14df66f92cc008075e09b73fc48997753 100644 (file)
@@ -59,19 +59,16 @@ src_compile() {
 
        if use egl; then
                emake LDLIBS="-lEGL" -C src/egl/opengl/ eglinfo
-               emake -C src/egl/eglut/ libeglut_screen.la libeglut_x11.la
+               emake -C src/egl/eglut/ libeglut_x11.la
                emake LDLIBS="-lGL -lEGL -lX11 -lm" -C src/egl/opengl/ eglgears_x11
-               emake LDLIBS="-lGL -lEGL -lm" -C src/egl/opengl/ eglgears_screen
 
                if use gles1; then
                        emake LDLIBS="-lGLESv1_CM -lEGL -lX11" -C src/egl/opengles1/ es1_info
                        emake LDLIBS="-lGLESv1_CM -lEGL -lX11 -lm" -C src/egl/opengles1/ gears_x11
-                       emake LDLIBS="-lGLESv1_CM -lEGL -lm" -C src/egl/opengles1/ gears_screen
                fi
                if use gles2; then
                        emake LDLIBS="-lGLESv2 -lEGL -lX11" -C src/egl/opengles2/ es2_info
                        emake LDLIBS="-lGLESv2 -lEGL -lX11 -lm" -C src/egl/opengles2/ es2gears_x11
-                       emake LDLIBS="-lGLESv2 -lEGL -lm" -C src/egl/opengles2/ es2gears_screen
                fi
        fi
 }
@@ -79,14 +76,13 @@ src_compile() {
 src_install() {
        dobin src/xdemos/{glxgears,glxinfo}
        if use egl; then
-               dobin src/egl/opengl/egl{info,gears_{screen,x11}}
+               dobin src/egl/opengl/egl{info,gears_x11}
 
                if use gles1; then
                        dobin src/egl/opengles1/es1_info
-                       newbin src/egl/opengles1/gears_screen es1gears_screen
                        newbin src/egl/opengles1/gears_x11 es1gears_x11
                fi
 
-               use gles2 && dobin src/egl/opengles2/es2{_info,gears_{screen,x11}}
+               use gles2 && dobin src/egl/opengles2/es2{_info,gears_x11}
        fi
 }
index 657291fc1e391145453f6d271963f1b59241a082..778c9076fa9af6a522cc47c15df008f7fee46e9f 100644 (file)
@@ -59,19 +59,16 @@ src_compile() {
 
        if use egl; then
                emake LDLIBS="-lEGL" -C src/egl/opengl/ eglinfo
-               emake -C src/egl/eglut/ libeglut_screen.la libeglut_x11.la
+               emake -C src/egl/eglut/ libeglut_x11.la
                emake LDLIBS="-lGL -lEGL -lX11 -lm" -C src/egl/opengl/ eglgears_x11
-               emake LDLIBS="-lGL -lEGL -lm" -C src/egl/opengl/ eglgears_screen
 
                if use gles1; then
                        emake LDLIBS="-lGLESv1_CM -lEGL -lX11" -C src/egl/opengles1/ es1_info
                        emake LDLIBS="-lGLESv1_CM -lEGL -lX11 -lm" -C src/egl/opengles1/ gears_x11
-                       emake LDLIBS="-lGLESv1_CM -lEGL -lm" -C src/egl/opengles1/ gears_screen
                fi
                if use gles2; then
                        emake LDLIBS="-lGLESv2 -lEGL -lX11" -C src/egl/opengles2/ es2_info
                        emake LDLIBS="-lGLESv2 -lEGL -lX11 -lm" -C src/egl/opengles2/ es2gears_x11
-                       emake LDLIBS="-lGLESv2 -lEGL -lm" -C src/egl/opengles2/ es2gears_screen
                fi
        fi
 }
@@ -79,14 +76,13 @@ src_compile() {
 src_install() {
        dobin src/xdemos/{glxgears,glxinfo}
        if use egl; then
-               dobin src/egl/opengl/egl{info,gears_{screen,x11}}
+               dobin src/egl/opengl/egl{info,gears_x11}
 
                if use gles1; then
                        dobin src/egl/opengles1/es1_info
-                       newbin src/egl/opengles1/gears_screen es1gears_screen
                        newbin src/egl/opengles1/gears_x11 es1gears_x11
                fi
 
-               use gles2 && dobin src/egl/opengles2/es2{_info,gears_{screen,x11}}
+               use gles2 && dobin src/egl/opengles2/es2{_info,gears_x11}
        fi
 }