dev-python/pygtk: Fix build against x11-libs/pango-1.44
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 25 Jan 2020 20:07:05 +0000 (21:07 +0100)
committerMart Raudsepp <leio@gentoo.org>
Sun, 15 Mar 2020 19:37:13 +0000 (21:37 +0200)
Source: https://github.com/flathub/org.glimpse_editor.Glimpse/blob/master/patches/pygtk-Drop-the-PangoFont-find_shaper-virtual-method.patch

Thanks-to: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com>
Closes: https://bugs.gentoo.org/703052
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-python/pygtk/files/pygtk-2.24.0-pango-1.44.patch [new file with mode: 0644]
dev-python/pygtk/pygtk-2.24.0-r5.ebuild

diff --git a/dev-python/pygtk/files/pygtk-2.24.0-pango-1.44.patch b/dev-python/pygtk/files/pygtk-2.24.0-pango-1.44.patch
new file mode 100644 (file)
index 0000000..b4ed200
--- /dev/null
@@ -0,0 +1,41 @@
+From 4aaa48eb80c6802aec6d03e5695d2a0ff20e0fc2 Mon Sep 17 00:00:00 2001
+From: Jordan Petridis <jpetridis@gnome.org>
+Date: Thu, 24 Oct 2019 22:58:36 +0200
+Subject: [PATCH] Drop the PangoFont find_shaper virtual method
+
+This API has been removed from Pango 1.44.6, because it was completely
+unused by anything.
+
+However, PyGTK tries to bind everything, even unused API.
+
+Removing this from PyGTK means we can build it against the latest Pango
+again.
+
+https://gitlab.gnome.org/GNOME/pango/issues/417
+---
+ pango.defs | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/pango.defs b/pango.defs
+index 6935c964..da968f58 100644
+--- a/pango.defs
++++ b/pango.defs
+@@ -1391,15 +1391,6 @@
+   )
+ )
+-(define-virtual find_shaper
+-  (of-object "PangoFont")
+-  (return-type "PangoEngineShape*")
+-  (parameters
+-    '("PangoLanguage*" "lang")
+-    '("guint32" "ch")
+-  )
+-)
+-
+ (define-virtual get_glyph_extents
+   (of-object "PangoFont")
+   (return-type "none")
+-- 
+2.24.1
+
index 094ca5ba9e024486d35180f99b3dd8d5125b2d1b..f86cab545d536bdf5978c297a23b5b55a7be58ff 100644 (file)
@@ -50,6 +50,8 @@ PATCHES=(
        "${FILESDIR}/${P}-test_dialog.patch"
        # Fix build on Darwin
        "${FILESDIR}/${PN}-2.24.0-quartz-objc.patch"
+       # x11-libs/pango-1.44
+       "${FILESDIR}/${PN}-2.24.0-pango-1.44.patch"
 )
 
 src_prepare() {