app-emacs/nxml-libvirt-schemas: Version bump.
authorUlrich Müller <ulm@gentoo.org>
Tue, 15 Oct 2019 10:12:28 +0000 (12:12 +0200)
committerUlrich Müller <ulm@gentoo.org>
Tue, 15 Oct 2019 10:12:43 +0000 (12:12 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/nxml-libvirt-schemas/Manifest
app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-5.8.0.ebuild [new file with mode: 0644]

index ee692887a736d7085b9c21eaa15580e7db2f2e7f..3f8638db7b3ac02f642a72db5e75654a9190565d 100644 (file)
@@ -1 +1,2 @@
 DIST libvirt-1.2.1.tar.gz 27228694 BLAKE2B 5552508f87bddbd8d2dd65a37298f7f7e7238a7ac5aeef878bd8b3c6d5ecab8f2cf6fb94c8d520312b6c6399f1e663f8d68febf2badd544020635df841f5488f SHA512 6184840623156ca01ee7f59078ebf031bc84c25b37bb110372c7bcf230a79b74e267475f989fb73db5e3c096dcc74f03cb30adfc5de022f756ed2cd6ab05bfd0
+DIST libvirt-5.8.0.tar.xz 13129328 BLAKE2B ff49b0b6dca86f35c68edfb880677c88e0aed8021ed01ebd145922821914edd70c355ca777fe470e2b0e4baf36f2813c1100be9377344f81c9df374068307da1 SHA512 73d18fdf307b8029921a9f1a0c84ca31c50c662a3c0339e3850d6d2f31574168807a6f34943b286ed86a44031decbbc1339f27366da7269e29d38c7094503113
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-5.8.0.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-5.8.0.ebuild
new file mode 100644 (file)
index 0000000..ef9c1c6
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+MY_P="libvirt-${PV}"
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="http://www.libvirt.org/"
+SRC_URI="http://libvirt.org/sources/${MY_P}.tar.xz"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+BDEPEND="app-text/trang"
+
+SITEFILE="60${PN}-gentoo.el"
+S="${WORKDIR}/${MY_P%-rc*}"
+
+src_compile() {
+       emake -C docs/schemas -f "${FILESDIR}"/Makefile-trang
+}
+
+src_install() {
+       insinto "${SITEETC}/${PN}"
+       doins "${FILESDIR}"/schemas.xml docs/schemas/*.rnc
+       elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}