sys-libs/compiler-rt: Use BDEPEND semi-properly
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:21 +0000 (23:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:53 +0000 (23:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
sys-libs/compiler-rt/compiler-rt-9.0.0.9999.ebuild

index b6bc66629c35fa03e0dc3236c134c48d732e6667..13a5397acde0a4af6a3804dfc4999671dc484b14 100644 (file)
@@ -26,7 +26,8 @@ RESTRICT="!test? ( test ) !clang? ( test )"
 CLANG_SLOT=${SLOT%%.*}
 # llvm-6 for new lit options
 DEPEND="
-       >=sys-devel/llvm-6
+       >=sys-devel/llvm-6"
+BDEPEND="
        clang? ( sys-devel/clang )
        test? (
                $(python_gen_any_dep "dev-python/lit[\${PYTHON_USEDEP}]")
index 3b0033468a96a36c25f6600ad00d998a3c68a2f2..88bfd8aa0ad293d3d68618fdfbfebb5f2acdc492 100644 (file)
@@ -27,7 +27,8 @@ RESTRICT="!test? ( test ) !clang? ( test )"
 CLANG_SLOT=${SLOT%%.*}
 # llvm-6 for new lit options
 DEPEND="
-       >=sys-devel/llvm-6
+       >=sys-devel/llvm-6"
+BDEPEND="
        clang? ( sys-devel/clang )
        test? (
                $(python_gen_any_dep "dev-python/lit[\${PYTHON_USEDEP}]")