dev-libs/libsass: new package
authorAlexandre Rostovtsev <tetromino@gentoo.org>
Tue, 7 Nov 2017 08:25:25 +0000 (03:25 -0500)
committerAlexandre Rostovtsev <tetromino@gentoo.org>
Tue, 7 Nov 2017 08:34:21 +0000 (03:34 -0500)
Package-Manager: Portage-2.3.13, Repoman-2.3.4

dev-libs/libsass/Manifest [new file with mode: 0644]
dev-libs/libsass/libsass-3.4.5.ebuild [new file with mode: 0644]
dev-libs/libsass/libsass-9999.ebuild [new file with mode: 0644]
dev-libs/libsass/metadata.xml [new file with mode: 0644]

diff --git a/dev-libs/libsass/Manifest b/dev-libs/libsass/Manifest
new file mode 100644 (file)
index 0000000..1642f26
--- /dev/null
@@ -0,0 +1 @@
+DIST libsass-3.4.5.tar.gz 318689 SHA256 fd0cb47479b4eae03154f23e17ab846aa81ba168c9aa5fa493b8fa42d10842c8 SHA512 5e3f56d44d100067d68e338fa97209a78d80c3536d64fdf48d83ec5351f944dbbe50e1050ffc8189b3ae86fd86d7b121229a3866f6e0287abc55af3770ed2bb6 WHIRLPOOL 852c61f4b7f3999a1d9de9e0075a4358e2323054797acbd2dd396b3486fcb655350897c1c65b55a5ec02f24dd62c771648b756911cbbcf48e519775b6afbf736
diff --git a/dev-libs/libsass/libsass-3.4.5.ebuild b/dev-libs/libsass/libsass-3.4.5.ebuild
new file mode 100644 (file)
index 0000000..a220ac3
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils ltprune multilib-minimal
+
+if [[ ${PV} = *9999 ]]; then
+       EGIT_REPO_URI="https://github.com/sass/libsass.git"
+       inherit git-r3
+       KEYWORDS=
+else
+       SRC_URI="https://github.com/sass/libsass/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
+
+DESCRIPTION="A C/C++ implementation of a Sass CSS compiler"
+HOMEPAGE="https://github.com/sass/libsass"
+LICENSE="MIT"
+SLOT="0/0" # libsass soname
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+DOCS=( Readme.md SECURITY.md )
+
+src_prepare() {
+       default
+
+       if [[ ${PV} != *9999 ]]; then
+               [[ -f VERSION ]] || echo "${PV}" > VERSION
+       fi
+       eautoreconf
+
+       # only sane way to deal with various version-related scripts, env variables etc.
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               --enable-shared
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" install
+       prune_libtool_files
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       dodoc -r "${S}/docs"
+}
diff --git a/dev-libs/libsass/libsass-9999.ebuild b/dev-libs/libsass/libsass-9999.ebuild
new file mode 100644 (file)
index 0000000..6c86860
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils ltprune multilib-minimal
+
+if [[ ${PV} = *9999 ]]; then
+       EGIT_REPO_URI="https://github.com/sass/libsass.git"
+       inherit git-r3
+       KEYWORDS=
+else
+       SRC_URI="https://github.com/sass/libsass/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
+
+DESCRIPTION="A C/C++ implementation of a Sass CSS compiler"
+HOMEPAGE="https://github.com/sass/libsass"
+LICENSE="MIT"
+SLOT="0/1" # libsass soname
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+DOCS=( Readme.md SECURITY.md )
+
+src_prepare() {
+       default
+
+       if [[ ${PV} != *9999 ]]; then
+               [[ -f VERSION ]] || echo "${PV}" > VERSION
+       fi
+       eautoreconf
+
+       # only sane way to deal with various version-related scripts, env variables etc.
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               --enable-shared
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" install
+       prune_libtool_files
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       dodoc -r "${S}/docs"
+}
diff --git a/dev-libs/libsass/metadata.xml b/dev-libs/libsass/metadata.xml
new file mode 100644 (file)
index 0000000..0208c3a
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+       <email>tetromino@gentoo.org</email>
+       <name>Alexandre Rostovtsev</name>
+</maintainer>
+<longdescription lang="en">
+       LibSass is a C++ port of the original Ruby Sass CSS compiler with a C
+       API. It is coded LibSass with portability and efficiency in mind. You
+       can expect LibSass to be a lot faster than Ruby Sass and on par or
+       faster than the best alternative CSS compilers around.
+</longdescription>
+<upstream>
+       <remote-id type="github">sass/libsass</remote-id>
+</upstream>
+</pkgmetadata>