dev-python/serverfiles: Enable py3.{7,8}, modernize
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 09:27:45 +0000 (11:27 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 10:17:05 +0000 (12:17 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/serverfiles/serverfiles-0.2.1.ebuild

index 6fc585fcc3a02e0cbcc2a13e731a5aef5727b1de..bfb83aa8637e9edf7c9934811be1e7967ebb684e 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_6)
+PYTHON_COMPAT=( python3_{6,7,8} )
 inherit distutils-r1
 
 DESCRIPTION="Utility for accessing HTTP server and storing files locally for reuse"
@@ -13,15 +13,10 @@ SRC_URI="https://github.com/biolab/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-3+"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND=">=dev-python/requests-2.11.1[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
+DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]"
 
-python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest