app-vim/vimpython-1.13-r3: revbump, move to eapi=7, add py3{7,8}
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 24 Apr 2020 18:12:16 +0000 (11:12 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 24 Apr 2020 18:12:16 +0000 (11:12 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-vim/vimpython/vimpython-1.13-r3.ebuild [new file with mode: 0644]

diff --git a/app-vim/vimpython/vimpython-1.13-r3.ebuild b/app-vim/vimpython/vimpython-1.13-r3.ebuild
new file mode 100644 (file)
index 0000000..9f704f7
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: A set of menus/shortcuts to work with Python files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=30"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"