dev-python/translate-toolkit: Drop python3_8 from 2.4.0
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 16 Apr 2020 23:32:07 +0000 (01:32 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 00:04:02 +0000 (02:04 +0200)
Proper support according to upstream in >=2.5.0.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/translate-toolkit/translate-toolkit-2.4.0.ebuild

index 47d469e37696866d43294a93a78ca3c925cc664a..95b94c3da3706c1f4fa8f735a88f3c78ee58b95c 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7} )
 PYTHON_REQ_USE="sqlite"
 
 inherit distutils-r1
@@ -17,8 +17,7 @@ SLOT="0"
 KEYWORDS="amd64 arm64 x86 ~amd64-linux ~x86-linux"
 IUSE="doc +html +ical +ini +subtitles +yaml"
 
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
-       subtitles? ( || ( $(python_gen_useflags python3_6 python3_7) ) )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
@@ -38,7 +37,7 @@ RDEPEND="${DEPEND}
        html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
        ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
        ini? ( dev-python/iniparse[${PYTHON_USEDEP}] )
-       subtitles? ( $(python_gen_cond_dep 'media-video/gaupol[${PYTHON_USEDEP}]' python3_6 python3_7) )
+       subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
        yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
 "