dev-libs/libdnsres: EAPI=7
authorJeroen Roovers <jer@gentoo.org>
Sun, 5 Jan 2020 15:26:23 +0000 (16:26 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 5 Jan 2020 15:28:53 +0000 (16:28 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild b/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild
new file mode 100644 (file)
index 0000000..99fa345
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A non-blocking DNS resolver library"
+HOMEPAGE="https://www.monkey.org/~provos/libdnsres/"
+SRC_URI="https://www.monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+PATCHES=(
+       "${FILESDIR}"/${P}-autotools.patch
+)
+
+src_prepare() {
+       default
+       sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       find "${ED}" -name '*.la' -delete || die
+}